0

I installed Debian Testing on an Asus TP210S (ISO file downloaded from https://ftp.acc.umu.se/cdimage/unofficial/non-free/cd-including-firmware/buster_di_alpha4+nonfree/amd64/iso-cd/, not the "edu" one), but X won't start.

Here's Xorg.0.log from that laptop: https://pastebin.com/u8nJc5pr.

I installed the packages intel-microcode and firmware-misc-nonfree but it still doesn't start X. When I query lsmod|grep -i vga nothing is returned. The package xserver-xorg-video-intel is installed; I report on this because the last time I had this problem on another laptop, it was solved by installing this package.

On running inxi -Gx I found out that the driver loaded is modsetting, and it marks fbdev, vesa as unloaded; when trying to load vesa I get the error FATAL: Module vesa not found in directory /lib/modules/4.19.0-4-amd64/; when I try loading fbdev no error is produced but then I run lsmod|grep fbdev and nothing appears.

Here's the output of lsmod|grep -i video:

uvcvideo              118784  0
videobuf2_vmalloc      16384  1 uvcvideo
videobuf2_memops       16384  1 videobuf2_vmalloc
videobuf2_v4l2         28672  1 uvcvideo
videobuf2_common       53248  2 videobuf2_v4l2,uvcvideo
videodev              212992  3 videobuf2_v4l2,uvcvideo,videobuf2_common
media                  45056  2 videodev,uvcvideo
usbcore               290816  4 xhci_hcd,uvcvideo,btusb,xhci_pci
video                  45056  2 asus_wmi,i915

Two other things:

  1. Whenever I start the laptop, one of the first messages on screen is "Resuming from hibernation", which is quite odd because I just installed the system and haven't enabled hibernation (and I'm not planning on doing it).
  2. If left to itself, after about 5 minutes without a login, the laptop will automatically shutdown. Any suggestions? I really want to install Testing on this one, specifically because of the more updated version of TeXLive, and because I bought this laptop to use at the office.
1

Someone answered this one on the Debian forums: http://forums.debian.net/viewtopic.php?f=10&t=141915&p=698118#p698118

The steps are: 1. Log in as root, or boot on single user mode (that's the suggestion in the post). 2. Run 'Xorg -configure'; this generates a file named xorg.conf.new. 3. Copy this file to /usr/share/X11/xorg.conf.d/xorg.conf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.