0

i'm trying to install mysql 8.0.15-1debian9 on a debian 9 server

the problem is that mysql only provides the latest version of mysql in their apt repository which is 8.0.16-1debian9

however 8.0.16-1debian9 is still available in their apt repo

i'm trying to install it with the following task ( mysql official repo is also installed)

- name: Install MySQL 8.0.15 Community Server
  apt:
    deb: http://repo.mysql.com/apt/debian/pool/mysql-8.0/m/mysql-community/mysql-community-server_8.0.15-1debian9_amd64.deb

which fails with this error

  msg: |-
    Dependency is not satisfiable: mysql-client (= 8.0.15-1debian9)

is there any clear work around for this ?

i want to avoid shell and command module as much as possible .

  • This may help wiki.archlinux.org/index.php/Pacman/Rosetta – Biswapriyo May 4 at 19:47
  • Are you able to install it from the command line? Why do you think it is Ansible problem? – Vladimir Botka May 4 at 20:07
  • @Biswapriyo i couldn't find any specific command to use – shalbafzadeh May 4 at 22:38
  • @VladimirBotka no i couldn't install it from command line . it's not a Ansible problem at all , i just want to do it via Ansible – shalbafzadeh May 4 at 22:39
  • 2
    @shalbafzadeh Ansible can't help you if you are not able to configure it from the command line. Very probably you need to fix the repositories. Try from the command line first and then proceed with apt_repository and apt. – Vladimir Botka May 5 at 7:46
1

As we can use apt, this way:

apt-get install mysql=8.0.15-1debian9

We may able to use the ansible apt module the same way:

apt: name=mysql=8.0.15-1debian9 state=installed

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.