shadowsocks is working well on my mac.

I have tried a lot of tutorials to setup shadowsocks client on centos 6.6 in vm fusion, none of them work.

sudo yum install epel-release
sudo yum -y install python-pip
sudo yum -y install libsodium
sudo pip install https://github.com/shadowsocks/shadowsocks/archive/master.zip -U
sudo nano /etc/shadowsocks.json
# paste the same configuration that works well on my mac
sudo sslocal -c /etc/shadowsocks.json -d start

So far, everything goes well. curl http://httpbin.org/ip returns the IP successfully though, --socks5 param produces

couldn't connect to host

with this configuration:

enter image description here

i've tried to set "No proxy for" as localhost, or empty, none of them worked.

Firefox cannot access anything.

Any clues?

this is not about shadowsocks-qt5.


According to your tutorial , your shadowsocks client ( ss-local ) exposes a SOCKS-5 proxy , and you can use that SOCKS-5 proxy for all your connections in Firefox , but as it shows in your screenshot , you are using the HTTP proxy section of your Firefox , just fill out the SOCKS5 section and remove HTTP proxy section on your Firefox proxy settings and it should work just fine , but if you you need to use the HTTP proxy on port 1080 , you can use the Qt5 version the Qt5 version is working very well for me and you have greater control over your proxy settings .


it has a nice GUI and it opens a http/s proxy on port 1080 that can be used as you global proxy or Firefox proxy .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.