0

[5.0.9-arch1-1-ARCH with gnome-desktop 3.32.1.2-1 and tracker 2.2.1]

This is a follow-up on a previous answered question, where I unmasked the tracker-store.service, which was spamming my syslog at boot already and disabled the search option in Nautilus from the GUI. I also erased the complete database index, with $ tracker reset --hard, as I never use Nautilus.

The message that spams my syslog is:

dbus-daemon[1492]: [session uid=1000 pid=1492] Activation via systemd failed for unit 'tracker-extract.service': Unit tracker-extract.service is masked.

... most of those lines forming a repeat sequence, as obtained from: $ sudo journalctl -b. The number of occurences increases rapidly with time, at an coarsely estimated rate of 1200/min.

The truncated syslog listing is here. (It is way too big to upload whole.) I checked that I actually have no tracker-extract.service unit active, enabled, or masked. The tracker-extract service unit does not appear in:

$ sudo systemctl list-dependencies --all | grep -e extract -e tracker
  • 1
    You can help answerers by showing whether you have the tracker-miners package installed, and using the --user flag to systemctl. – JdeBP May 4 at 7:32
0

The idea behind this answer is simple. Also look at user name space, not just at system's namespace when it comes to troubleshooting syslog. The merit for reminding me of this is entirely @JdeBP's.

Following his suggestion, I used the --user flag to un-mask the service unit for the calling user, rather than by invoking the service manager of the system.

$ pacman -Ss tracker-miners
extra/tracker-miners 2.2.2-1 (gnome) [installed]
Collection of data extractors for Tracker/Nepomuk

confirms (if necessary) that tracker-miners is installed.

$ systemctl --user unmask tracker-extract.service
Removed /home/<USER>/.config/systemd/user/tracker-extract.service
$ systemctl --user list-unit-files tracker-extract.service
UNIT FILE               STATE
tracker-extract.service static
1 unit files listed.

resulted in the tracker-extract service not being flagged as "masked" by dbus-daemon. Spamming of my syslog stopped immediately afterwards.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.