0

I'm currently doing a microcontroller project that requires a serial port, but for testing purposes, I require two serial ports and terminals working with both of them.

My computer has one native serial port with no issues.

I tried using USB to serial adapters and some partially work while others do not work at all.

Now I'm trying an older PCMCIA serial adapter and I couldn't get it to work despite the various ideas presented on the internet including from here: http://www.electronicsfaq.com/2010/02/getting-serial-port-to-work-under.html

I also followed the instructions presented on the included driver CD and I'm told "/dev/ttyS4" doesn't exist when I run the executable. Perhaps I should somehow create it?

I also executed "setserial /dev/ttyS* uart 16550" on an existing /dev/ttyS* device that matches the same IRQ and port number as what the adapter provided. I used commands "setserial -gv /dev/ttyS*" and "lspci -v". The system happily accepted the uart assignment no problem.

When I executed "screen /dev/ttyS* 9600", the system locks up in graphical X window mode and I have to manually restart the computer.

I tried the same procedure again without loading the X org graphical system and I constantly get a message from serial8250 driver stating there's too much work for the same IRQ the PCMCIA card is using.

I also noticed that my wireless network card is also using that IRQ but during the tests, I wasn't even using that network card.

What's the best thing to do?

Should I just somehow create a /dev/ttyS4 with special properties and just load the driver? or should I load some different driver? or should I disable other parts of my system to get the adapter to work? or is my only real option to buy a more ancient laptop with two serial ports built-in?

My linux is slackware 13 (kernel 2.9) and I'm running a dell laptop.

0

I can't help with your PCMCIA issue, but I use Gnuscreen every day with cheap $0.90 USB/3.3 volt serial dongles under FreeBSD or Linux. The main issue is that your OS has a driver for them.

I find USB/serial dongles with the CP2102 and PL2303 chipsets work perfectly and recommend ones which have RTS, CTS, DTR, etc., available apart from the usual RX, Tx, 3.3 and 5v.

This is the type of script I use to initiate a serial connection using such a dongle. The device is for FreeBSD and I'm using CTS/RTS hardware handshaking

xterm -fs 12 -title 'GnuScreen@cuaU0:460800 bps | CTRL A :quit | ' -geometry 82x72+0+0 -e screen -t my-screen-session -S  my-screen-session /dev/cuaU0 460800,crtscts &

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.