1

Recently tried booting up my server but i get the following error. It seems that initramfs is not able to generate and i tried to boot into rescue mode and found that fstab file was empty. Updated the file, but no luck. I have attached the image since im unable to copy the lines.

DRACUT MODE IN CENTOS7

2

Welcome to Unix&Linux StackExchange!

The error comes from initramfs, and the main problem is apparently described by

 dracut-initqueue[217]: Warning: /dev/disk/by-uuid/fea3e633-5380-4b23-86e0-8dd8442b4404 does not exist

In other words, using the storage drivers available within the initramfs, the root filesystem specified by that UUID cannot be found.

Does the GRUB boot menu include older kernel versions? If it does, what happens if you try booting with an older kernel?

If booting with an older kernel doesn't work, you might want to boot the system into rescue mode using CentOS installation media, or use another live Linux media to boot the system to investigate. If the blkid command cannot find the UUID listed in the error message on any of the disks, there are several possible reasons:

  • Missing driver? Some modern servers use a "BIOS RAID" that requires a specific driver from the hardware vendor. You might need to take extra steps to load this driver in the rescue/LiveOS environment. The error might be caused by updating the kernel on the server but failing to install the corresponding driver update from the vendor.

  • GRUB/initramfs configuration error? The root filesystem can be specified with the kernel boot parameters, and a mistake in editing GRUB configuration might have caused it to refer to a wrong filesystem. You would need to identify the correct UUID for the root filesystem and correct the configuration. Fixing the actual GRUB configuration file /boot/grub/grub.cfg or /boot/efi/EFI/centos/grub.cfg won't be enough; you'll also need to fix the file that is used in the automatic GRUB reconfiguration process when installing kernel updates. That file should be /etc/default/grub.

  • Root filesystem corrupted or overwritten? You said that you tried to boot in rescue mode but found /etc/fstab empty - exactly how did you do that? If that was the Dracut Emergency Shell, that runs in the initramfs environment and might well have an empty /etc/fstab file.

But if you actually booted from a separate media and successfully mounted the device that was supposed to contain the root filesystem, and found an empty /etc/fstab file, that suggests something very bad may have happened to that filesystem. In that case, I hope you have good backups.

0

I had this issue when I had to remove a LV /dev/mapper/swap

once I removed it, rebooting caused an issue with dracut

solution was to edit 2 files,

vim /boot/efi/EFI/centos/grub.cfg 
vim /etc/default/grub

remove any rference to swap,

rd.vlm.lv=centos/swap (remove this whole string from both files + reboot)

enter image description here

1
  • 1
    Do not post screenshots of terminals. Copy the text instead. Jul 15 '20 at 21:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.