1

Please see the short GIF recorded screencast of the problem in action. This is how all videos open and play, I cannot see a darn thing, just these big colored bars where the color is taken from the actual video.

Anybody have any thoughts on why this is happening with only my VLC Media Player? I recently re-installed Manjaro Linux but I still can't pinpoint the problem to why its happening only with VLC.

GIF video screencast of the problem in action

Clarification: VLC is the only media player doing this, all other media players such as MPV, MPlayer, etc. are working normally.

[UPDATE] Here is the debugging output when playing a video from terminal:

[anony@mous-pc]$ vlc video-clip-1.MTS 
VLC media player 3.0.6 Vetinari (revision 3.0.6-0-g5803e85f73)
[0000559356a92570] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
qt5ct: using qt5ct plugin
qt5ct: D-Bus global menu: no
qt5ct: D-Bus system tray: no
[00007f4300005fd0] glconv_vaapi_x11 gl error: vaDeriveImage: invalid VASurfaceID
[00007f4314006590] main video output error: video output creation failed
[00007f4310c101b0] main decoder error: failed to create video output
[00007f4310c101b0] avcodec decoder: Using G3DVL VDPAU Driver Shared Library version 1.0 for hardware decoding

This was done with an .MTS video but I can confirm it is doing the exact same with .mp4 too, also with .avi as well.

  • 3
    When you say "only with VLC", does that mean you've tried another video player (e.g., mpv) and that one works? Or that VLC is the only video player you've tried, but other apps are working fine? – derobert May 2 at 15:17
  • Of course it means I have tried others when I say its only doing this with VLC. – Anonymous May 3 at 2:33
  • Run vlc yourmediafile from terminal to see if you get some errors / warnings. Alternately can turn on logger for debugging within vlc. – user174174 May 3 at 9:45
  • Oh very good idea! Okay will try and report back. – Anonymous May 6 at 3:41
  • I have updated question with results. – Anonymous May 6 at 3:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.