1

We have an AIX 6.1 server which was working; it does not have most of the freeware packages:

root@srv/ins:rpm -qa
cdrecord-1.9-7
mkisofs-1.13-4
vnc-3.3.3r2-6
openssl-0.9.7l-2
unzip-5.51-1
bash-4.2-3
AIX-rpm-6.1.8.15-12

We needed node.js, so I tried to install its dependencies from bullfreeware.com website using the rpm -ivh command. Finally, I got the node program working at this state:

root@srv/ins:rpm -qa
cdrecord-1.9-7.ppc
mkisofs-1.13-4.ppc
AIX-rpm-6.1.8.15-29.ppc
gdbm-1.12-1.ppc
bzip2-1.0.6-3.ppc
libffi-3.2.1-3.ppc
libstdc++-devel-6.3.0-2.ppc
info-6.4-1.ppc
sqlite-3.27.1-1.ppc
mpfr-3.1.2-3.ppc
gcc-cpp-6.3.0-2.ppc
gcc-c++-6.3.0-2.ppc
ca-certificates-2017.07.17-1.ppc
rsync-3.1.3-2.ppc
gettext-0.19.8.1-3.ppc
openssl-1.1.0g-1withsslv2.ppc
python-2.7.16-1.ppc
libidn-1.24-1.ppc
openldap-2.4.46-1.ppc
xz-libs-5.2.4-1.ppc
libunistring-0.9.9-2.ppc
libICE-1.0.8-1.ppc
shared-mime-info-1.6-1.ppc
libpng-1.6.27-2.ppc
libtiff-4.0.6-2.ppc
vim-common-7.4-4.ppc
pixman-0.34.0-1.ppc
fontconfig-2.11.95-2.ppc
atk-2.20.0-2.ppc
xcb-proto-1.12-1.ppc
libX11-1.6.3-1.ppc
libXrandr-1.4.2-1waixX11.ppc
unzip-5.51-1.ppc
bash-4.2-3.ppc
vnc-3.3.3r2-6.ppc
libgcc-6.3.0-2.ppc
perl-5.28.1-1.ppc
expat-2.2.6-1.ppc
libstdc++-6.3.0-2.ppc
ncurses-6.1-2.ppc
readline-8.0-1.ppc
zlib-1.2.11-1.ppc
gmp-6.1.2-1.ppc
libmpc-1.0.3-1.ppc
gcc-6.3.0-2.ppc
grep-3.1-1.ppc
db-6.2.32-2.ppc
less-487-1.ppc
glib2-2.56.1-2.ppc
libssh2-1.8.0-1.ppc
libiconv-1.14-1.ppc
cyrus-sasl-2.1.26-3.ppc
curl-7.64.0-1ldapssl.ppc
libxml2-2.9.7-1.ppc
libyaml-0.1.7-1.ppc
libSM-1.2.1-1.ppc
libjpeg-9b-2.ppc
jbigkit-libs-2.0-3.ppc
gdk-pixbuf-2.35.1-1waixX11.ppc
freetype2-2.4.4-3.ppc
lzo-2.10-1.ppc
harfbuzz-1.2.6-1.ppc
pkg-config-0.25-3.ppc
libxcb-1.12-1waixX11.ppc
libXrender-0.9.9-1.ppc
root@srv:/opt/freeware/bin/node app.js 

... but npm would not work because of the git package, and git needs another version of gettext package, and gettext was a dependency of a lot of packages including AIX-rpm-6.1.8.15-30.ppc. I started using rpm -e to remove its dependents to install them after that; my last commands was:

root@srv/ins:rpm -e sqlite
root@srv/ins:rpm -e readline
error: Failed to initialize NSS library

after this point I was unable to install anything! Here is the error:

root@srv/ins:rpm -ivh sqlite-3.27.1-1.ppc.rpm
error: Failed dependencies:
    libc.a(shr.o) is needed by sqlite-3.27.1-1.ppc
    libc.a(shr_64.o) is needed by sqlite-3.27.1-1.ppc
    libgcc >= 6.3.0 is needed by sqlite-3.27.1-1.ppc
    libgcc_s.a(shr.o) is needed by sqlite-3.27.1-1.ppc
    libncurses.a(libncurses.so.6) is needed by sqlite-3.27.1-1.ppc
    libpthread.a(shr_xpg5.o) is needed by sqlite-3.27.1-1.ppc
    libpthread.a(shr_xpg5_64.o) is needed by sqlite-3.27.1-1.ppc
    libreadline.a(libreadline.so.7) is needed by sqlite-3.27.1-1.ppc
    libz.a(libz.so.1) is needed by sqlite-3.27.1-1.ppc
    ncurses >= 6.1 is needed by sqlite-3.27.1-1.ppc
    readline >= 7.0-5 is needed by sqlite-3.27.1-1.ppc
    zlib is needed by sqlite-3.27.1-1.ppc

What should I do now?

1

I finally solved the issue

1-Download rpm.rte package from ibm site and execute:

 installp -aXYF -d /path/to/rpm/rpm_rte rpm.rte

2-Download full gcc zip package for aix6.1(94mb) from bullfreeware.com and extract it in folder and install it using

rpm -Uvh *rpm

3-Download full git zip package excluding the packages installed in last step(130mb) and install it like step 2 and execute this:

export LIBPATH=/opt/freeware/lib64:/opt/freeware/lib:/usr/lib

4-Download and install cpio from bullfreeware.com and follow steps related to 2018-January 17th to fix libintl.so.9 issue like this:

rpm2cpio gettext-0.19.8-1.aix6.1.ppc.rpm | /opt/freeware/bin/cpio -iv opt/freeware/lib/libintl.a 
--> opt/freeware/lib/libintl.a 
# ar xv opt/freeware/lib/libintl.a libintl.so.9 
x - libintl.so.9 
# ar q /opt/freeware/lib/libintl.a libintl.so.9 
# ar -X64 xv opt/freeware/lib/libintl.a libintl.so.9 
x - libintl.so.9 
# ar -X64 q /opt/freeware/lib/libintl.a libintl.so.9 

I have installed cdrecord, vnc and mkisofs , just because they were installed last time. Final query on rpm was like this:

root@srv:/ins>rpm -qa
cdrecord-1.9-7.ppc
libgcc-8.3.0-1.ppc
libstdc++-8.3.0-1.ppc
mpfr-3.1.4-1.ppc
libmpc-1.0.3-2.ppc
libffi-3.2.1-2.ppc
libxml2-2.9.4-2.ppc
libiconv-1.14-22.ppc
bash-4.4-4.ppc
gcc-8.3.0-1.ppc
vnc-3.3.3r2-6.ppc
mkisofs-1.13-4.ppc
db-4.8.24-4.ppc
perl-5.28.0-1.ppc
expat-2.2.6-1.ppc
sqlite-3.7.15.2-3.ppc
rsync-3.1.2-3.ppc
unixODBC-2.3.6-2.ppc
libidn-1.35-1.ppc
less-481-1.ppc
python-2.7.15-5.ppc
git-2.21.0-6.ppc
lynx-2.8.4-2.ppc
AIX-rpm-6.1.8.15-7.ppc
zlib-1.2.11-1.ppc
gmp-6.1.1-1.ppc
ncurses-6.1-1.ppc
xz-libs-5.2.2-2.ppc
glib2-2.48.1-2.ppc
libunistring-0.9.6-2.ppc
gettext-0.19.8-1.ppc
info-6.4-1.ppc
gcc-cpp-8.3.0-1.ppc
unzip-6.0-3.ppc
readline-7.0-1.ppc
gdbm-1.10-1.ppc
openssl-1.1.0g-1withsslv2.ppc
libssh2-1.8.0-1.ppc
vim-common-7.4-4.ppc
libtool-ltdl-2.4.6-2.ppc
openldap-2.4.44-5.ppc
curl-7.64.0-1ldapssl.ppc
bzip2-1.0.6-2.ppc
vim-enhanced-7.4-4.ppc
cpio-2.12-2.ppc

4-Now extract node.js tar file in aix and execute this:

export PATH=$PATH:/path/to/nodejs/bin

5-Finally its done

node app.js

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.