0

My terminal emulators are lagging occasionally. It's not heavy a lag. May be once in 20-30 mins( I think). The terminal becomes unresponsive and all the characters I typed during lag appears suddenly. It's not happening in any other app (even in SMPLAYER during 1080p video playback). The lag occurs even during low memory usage(nearly 1 GB free). I thought there might be a problem in xterm and switched to xfce4-terminal emulator. problem still persisted. Then thought there might be a bug in bash and switched to zsh . still no luck. What's happening ? How can I narrow the down problem?
system info : Arch + i3 + compton
Update1: I thought my history size(1000) might be causing the problem and changed it to 100. And this doesn't seem to work either.
Update2: My ~/.bashrc


#
# ~/.bashrc
#

# If not running interactively, don't do anything
[[ $- != *i* ]] && return

alias ls='ls --color=auto'
alias grep='grep --color=auto'

PS1='\[\033[32m\]\u\[\033[33m\]@\[\033[36m\]\h \[\033[31m\]\W\[\033[33m\]\$\[\033[00m\]'


## my settings
alias vi='vim'
alias vi_i3='vim ~/.config/i3/config'
alias pacs='sudo pacman -S'
alias pacss='pacman -Ss'
alias pacsyu='sudo pacman -Syu'
export TERMINAL='xfce4-terminal'
HISTSIZE=100

Update3: But in zsh I used very simple Prompt string without any color. Still it was lagging.

  • Is there too much colors and aliases in .bashrc or .zshrc file? – Biswapriyo May 1 at 18:12
0

I've had this issue when my disk is full or some partition is filled. Be sure to check the health of the disk and check that you have adequate swap space on your system.

I also found someone with a very similar issue to yours at the site below

https://forum.manjaro.org/t/terminal-freezing-slow-to-respond/30647/15

Looks like the issue had something to do with the display driver. Let me know if this works for you.

  • my root partition is nearly 55GB free. And other partitions might have very less free space.I'll free them up and post the result. But why only terminal emulators suffer lag,not other apps? – Abinash Dash May 2 at 4:56
  • Tried that. Not working... Any other ideas? – Abinash Dash May 2 at 19:13
  • @AbinashDash I edited my post to show another possible answer to your issue. Please see response above ^^ – Gordster May 2 at 20:40
  • thanks @Gordster for the link. As far as I understood the post, the problem was related to compositor(compton). So instead of disabling it(as I like compositing very much). I tried sway wm(which uses wayland instead of xorg). Unfortunately, the problem occurred with sway too.... – Abinash Dash May 3 at 8:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.