2

I have this budget (read: cheapo) laptop, a Schneider SCL141-CTP, with an Intel Atom X5 Z-8350 SoC, 2 measly gigs of RAM and a ridiculously small 32GB eMMC SSD, that's running Windows 10 Home, and will soon be left on the platform when the 19H1 big update shows up, because I'll never manage to clear enough free space to satisfy Microsoft's requirements.

I've been wanting to install Linux on this laptop because I'm fed up no end with Windows, which barely works on such modest hardware, but all my attempts have proven unfruitful.

After a lot of hemming and hawing, I managed to shrink the C drive by 2GB using diskpart, formatted the newly created partition as FAT32, and used UNetBootIn to put the latest Debian-based Slax 9 distro on it, hoping to boot from it and run it live for a while, just to make sure it would fit my needs, before installing it for good.

Nowhere in the UNetBootIN window did I find the option you can have in Rufus to choose between GPT and MBR.

Problem is, this PC has UEFI, and though the UNetBootIN partition does show in the boot menu, selecting it and pressing Enter gets me an error message saying that a boot file is damaged or can't be read, or something like that, and only offers me to boot from Windows.

The file in question is, without surprise, ubnldr.mbr.

I tried to add it manually to the UEFI boot menu by pointing the menu at the correct file path, but it can't be found; instead, I'm proposed another 32-bit Linux loader that I'm not even sure is in the Slax files at all, "ia32-something".

No "ubnldr", just "ia32", and I can't go deeper into the tree line, it stops there.

I've tried to disable UEFI completely, hoping against hope that the PC would let me boot from the Slax partition.

Fat chance of that.

I can boot from Windows alright, so the laptop is fully operable, but I've got a (momentarily) useless 2GB partition containg Slax, and eating at what little free space I have.

  • Maybe try Fedora? – Freddy May 1 at 17:28
  • 1
    Thanks all for your support. I opted for Slax because it's tiny, and wouldn't take up too much space. Fedora, though compatible with UEFI (or so I've read here and there), would be too big. I've already checked the other links as part of my research prior to posting here, and I'm afraid they don't apply to my case, because I can't point the boot menu at the right bootloader. – Didier May 1 at 17:33
  • Just so you know: I added ia32boot.efi and a new copy of ubnldr.mbr in the Slax files I'd decompressed in that partition, and still no boot. I get the same error message stating that ubnldr.mbr is somewhat corrupted or unreadable, and would I like to boot from Windows instead, yes please? To say this is infuriating is an understatement... – Didier May 2 at 6:28
  • After much reading on the subject, it appears that decompressing the ISO on a partition set on the same disk as Windows leads Slax to disable adding a boot menu on top of Windows's, to prevent boot issues. Even if you want to run your Linux in live mode and not actually install it on your hard drive, be it your Windows partition or an ad-hoc one. Any input from your guys at this point? – Didier May 2 at 8:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.