0

I was wondering how to install an older Java application: http://al.chemy.org/

I downloaded the package for Linux, unzipped and launched alchemy.jar inside the package. The original installation notes couldn't be clearer to understand.

The problem I get an error message saying that alchemy.jar isn't able to find its modules (tools) so of course the app cannot start. The point is, the modules are there where they belong -inside their default folder, the same folder where executable is. Some ideas please?

Linux:Elementary Juno

  • Could you edit your question to show the exact error message you’re getting? Did you try starting alchemy.jar directly, or did you use one of the launchers? – Stephen Kitt May 2 at 11:47
  • Yes I stared Alchemy.jar directly and wondered afterwards why I had to use launcher scripts to do so. As a coder I myself know that adding two more handlers to check system specs would have been easy to implement. Why adding scripts if you can put all in one package? Maybe because of porting reasons.. But guys two handlers more kill no application... – Jarold May 3 at 8:43
1

Java can't find other jar files in the same directory without you explicitly telling it to. If you were running alchemy with:

java -jar alchemy.jar

Then you need to set the classpath to tell it where the other jar files are. Eg, if your "tools" are foo.jar and bar.jar run:

java -classpath "foo.jar:bar.jar" -jar alchemy.jar

If you need to add an entire directory (tools) you can:

java -classpath "tools/*" -jar alchemy.jar
  • Great news, i'm sure these commands will work. I come from a Mac Os environment where applications are executed in sandbox mode to do no harm to the system. This terminal-hacks so to say, weren't written in the install information's of this Java application. How should I know ? On Mac i the app worked out of the box, on elementary Linux not. I'll bookmark your help. Thanks! – Jarold May 1 at 10:50
  • Thanks. If this worked for you please accept the answer (tick to the left). – Philip Couling May 1 at 11:02
  • @Philip Alchemy doesn’t need any other JARs; this doesn’t explain the error (for what it’s worth, Alchemy works just fine for me on Java 8 and Java 11). – Stephen Kitt May 2 at 11:46
1

You should use the provided scripts to start Alchemy. In a terminal, go to the directory where you want to install Alchemy (your home directory is fine), and run:

tar xf /path/to/Alchemy-008.tar.gz

This will create an Alchemy directory, containing an Alchemy script which can be used to start the program:

/path/to/Alchemy/Alchemy

The script ensures that the current directory is the installation directory, which is what Alchemy expects in order to find its modules. You should be able to double-click on the script using your file manager if you prefer, instead of using the terminal.

  • I tried out both ways: Philip's first line of code worked perfectly, also right clicking and executing alchemyOpengl (which starts alchemy in a better rendering method) works. That's great. Finally, the place where I unpacked didn't matter and Alchemy.jar still refuses to run out of the box as it needs its configuration script. – Jarold May 3 at 8:19
  • I’m not sure I understand why you absolutely want alchemy.jar to work on its own. The tarball includes two executables to start the program, those are what you’re supposed to use (and they “just work”). – Stephen Kitt May 3 at 8:44
  • OK, the pre- configuration loader scripts are the executables to start Alchemy. The point is I can't double click these files. These are just documents and as such open in script/developer applications. – Jarold May 3 at 8:50
  • Ah, right, that’s an Elementary configuration issue; I don’t know what file manager Elementary uses, but if it’s the GNOME one, see this answer. – Stephen Kitt May 3 at 8:58
  • Yes I've the same folder tree. After setting to launch the document still opens in the code editor. That's unexpected and Juno related. Maybe a logout helps but I'm not sure that will do sth. At the end java -jar alchemy.jar works just fine but it doesn't matter as executing this in terminal or right clicking-execute the scripts differs not very much. A simple double click seems not possible XD not sure to whom I should give credits now. ^^ Thanks anyway, Stephen – Jarold May 3 at 10:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.