0

I am trying to install a package using apt-get on Debian. However, for some reason, it also wants to upgrade ca-certificates. Can I force apt-get install to skip upgrading ca-certificates as the upgrade is failing due to a read-only file system? I am looking for a workaround as I don't to mess up with the certificates of the host (it's a kubernetes api-server host).

enter image description here

2

The upgrade is failing because the file system is read-only, which means you won’t be able to install procps either.

The general answer to prevent upgrades is to put a hold on the package:

apt-mark hold ca-certificates

but in your case you might need to rebuild the container image instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.