0

The device is Octeon by Cavium which contains a RNG hardware unit. OS show Current entropy pool size is 4096 bytes but entropy_avail is very low.The device crypto modules has ansi_cprng.ko present only, no other RNG related .ko present, additionally as per lsmod no RNG related modules loaded. However, the kernel config settings related to RNG are as following; CONFIG_CRYPTO_ANSI_CPRNG=m CONFIG_CRYPTO_HW=y CONFIG_CRYPTO_RNG=m CONFIG_CRYPTO_RNG2=y

How to feed /dev/random from Octeon RNG and increase entropy_avail, please?

Thank you!

1

You need to load the cavium_rng module (enabled with CONFIG_HW_RANDOM_CAVIUM).

However, this is off-topic.

This is a question about Linux, not about cryptography, so the Unix StackExchange website would have been a better fit for it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.