0

I'm using rxvt-unicode as my terminal with Hack fonts patched with Nerd fonts. Also, my main editor is NeoVim (matters not), with vim-airline (among others).
So, this plugin (vim-airline) uses U+2630 and U+2632 font/char/unicode/glyph (onestly, I cannot make any difference, sorry), which is not present in my fonts. I have found that Symbola and Unifont, contains them, so I have tried to use Symbola as an fallback font. Here starts the problem.
My config works well, but those font/char/unicode/glyph are still not showing. More so, I have found the problem, that is URxvt*letterSpace = 0, anything bellow 1 is not rendering the font. To be more clear, letter spacing affects font rendering, if letter space is too small. Here are my questions; why is that happening, how can I avoid. As a first option I am searching if fonts spaces can be set on family base, thou it seems it is not possible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.