-1

Using Debian 9.8.

I encounter some troubles with some packages installation. Synaptics package manager offered me to do an upgrade and I accepted it, making my computer freezing at login screen after the reboot (with mouse not moving and so on : really stuck).

During boot, now, I can choose the previous version, before upgrade was applied : this one still work. Or recovery mode, that doesn't seems to end somewhere (I waited one minute only : was I too impatient ?)

Other times, when my computer seems queasy, I attempt a Ctrl-Alt-1. But I see only a blinking cursor, and no prompt...

I wonder if there is a combination of keys that at the time the computer is booting, forces him to go in console mode, without reaching GNOME the graphical environment I'm using.

I would like to see if my computer that frozes with the new upgrades when on GNOME login screen, is however able to start in console mode with all its new packages. And maybe, discover what happened ?

Solution (taken for your advices) : @GADR,

Welcome, Ctrl + Alt + F2 , then sudo dpkg --configure -a then try to update sudo apt update && sudo apt upgrade allowed me to reach the console, pressing that keys immediately after having selected the 4.9.0.9-amd64 that were going wrong. But no packages were broken.

@telcoM,

apt-get install --reinstall linux-image-4.9.0.9-amd64

succeeded in solving the problem.
Thanks a lot, everyone !

  • 2
    Welcome, Ctrl + Alt + F2 , then sudo dpkg --configure -a then try to update sudo apt update && sudo apt upgrade – GAD3R Apr 29 at 14:24
  • Debian is not working like ubuntu and sudo is not installed by default. – darxmurf Apr 29 at 14:44
  • 2
    @darxmurf that depends on how it was installed; if you don’t specify a root password then sudo is installed by default. – Stephen Kitt Apr 29 at 14:47
0

You can try to boot in init 3 mode. On grub screen type the letter e to edit the boot options, then goto the line starting with "linux" and add the number 3 in the end. Then press ctrl x to boot

0

Looks like something had gone wrong with the installation of the new kernel. If the system works normally if you select the previous kernel from the GRUB boot menu, this will be easy to fix.

First ensure you have plenty of free disk space. If the upgrade had left package files lying in apt's cache, running apt-get clean as root is an easy way to clean them up. It should be harmless: if apt needs those packages to install something else, it will simply download them again.

Then, run ls -l /boot/vmlinuz-* to determine the version number of the newest Debian kernel. At the time of this writing, Debian 9.9 was just released, so you will probably see /boot/vmlinuz-4.9.0-9-amd64 as the newest one, and so 4.9.0-9-amd64 is your latest kernel version.

To re-do the installation of the latest kernel package, run apt-get install --reinstall linux-image-<version of problem kernel> as root. Example:

# apt-get install --reinstall linux-image-4.9.0-9-amd64

The command will reinstall the specified kernel package, recreating any DKMS kernel modules and the initramfs file in the process. Depending on your CPU power and the number of DKMS module packages installed, this may take up to several minutes.

Once the command completes, you should be able to reboot normally.

  • But if there were no initramfs, the system wouldn't be able to boot at all. The OP is getting to the login screen, so the kernel has already been loaded. I don't see how this could be an initramfs issue. Sounds more like a graphics card problem. – terdon Apr 29 at 15:06
  • 1
    But the OP also says that booting with the old kernel works. Since that only changes the kernel, the associated modules, and initramfs, the problem is probably with one of them. If recreating the initramfs won't help, then perhaps the problem is with the kernel package, or with DKMS modules. Booting with the old kernel and running apt-get install --reinstall linux-image-<version of problem kernel> as root should have a good chance of fixing both of those. – telcoM Apr 29 at 15:16
  • 1
    Yes, but a new kernel requires new drivers, for that kernel. This is a common issue. You're quite right that the apt-get install --reinstall ... command will most likely fix it, I just don't think the discussion about initramfs is relevant. – terdon Apr 29 at 16:56
  • Sorry for the noise... I had initramfs on the brain because my Debian 9.9 upgrade just had a similar problem in which the cause was initramfs creation failure... similar, but not identical. – telcoM Apr 30 at 13:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.