0

I have OpenSuse Tumbledweed Desktop Environment. OS details are below -

rajkumar@localhost:~> cat /etc/os-release     
NAME="openSUSE Tumbleweed" 
# VERSION="20190426" 
ID="opensuse-tumbleweed" 
ID_LIKE="opensuse suse" 
VERSION_ID="20190426" 
PRETTY_NAME="openSUSE Tumbleweed" 
ANSI_COLOR="0;32" 
CPE_NAME="cpe:/o:opensuse:tumbleweed:20190426" 
BUG_REPORT_URL="https://bugs.opensuse.org" 
HOME_URL="https://www.opensuse.org/" 
LOGO="distributor-logo"

My install command is failing. The command details are below -

   rajkumar@localhost:~> sudo rpm -i Downloads/code-1.33.1-1554971173.el7.x86_64.rpm                                                                       error: Failed dependencies:
    libpthread.so.0()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libpthread.so.0(GLIBC_2.3.2)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libpthread.so.0(GLIBC_2.3.3)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libgtk-3.so.0()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libgdk-x11-2.0.so.0()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libatk-1.0.so.0()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libgio-2.0.so.0()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libpangocairo-1.0.so.0()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libgdk_pixbuf-2.0.so.0()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libcairo.so.2()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libpango-1.0.so.0()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libfreetype.so.6()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libfontconfig.so.1()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libgobject-2.0.so.0()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libdbus-1.so.3()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libXi.so.6()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libXcursor.so.1()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libXdamage.so.1()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libXrandr.so.2()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libXcomposite.so.1()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libXext.so.6()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libXfixes.so.3()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libXrender.so.1()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libX11.so.6()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libXss.so.1()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libXtst.so.6()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libgmodule-2.0.so.0()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    librt.so.1()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libglib-2.0.so.0()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libnss3.so()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libnssutil3.so()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libsmime3.so()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libnspr4.so()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libasound.so.2()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libcups.so.2()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libdl.so.2()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libexpat.so.1()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libstdc++.so.6()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libstdc++.so.6(GLIBCXX_3.4.10)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libstdc++.so.6(GLIBCXX_3.4.11)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libstdc++.so.6(GLIBCXX_3.4.14)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libstdc++.so.6(GLIBCXX_3.4.15)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libstdc++.so.6(GLIBCXX_3.4.9)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libm.so.6()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libm.so.6(GLIBC_2.2.5)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libgcc_s.so.1()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libgcc_s.so.1(GCC_3.0)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libgcc_s.so.1(GCC_4.0.0)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libc.so.6()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libc.so.6(GLIBC_2.11)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libc.so.6(GLIBC_2.2.5)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libc.so.6(GLIBC_2.3)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libc.so.6(GLIBC_2.3.2)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libc.so.6(GLIBC_2.3.4)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libc.so.6(GLIBC_2.4)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libc.so.6(GLIBC_2.6)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libc.so.6(GLIBC_2.7)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libc.so.6(GLIBC_2.9)(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libxcb.so.1()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libxkbfile.so.1()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64
    libsecret-1.so.0()(64bit) is needed by code-1.33.1-1554971173.el7.x86_64

How can I resolve this error?

1 Answer 1

0

You are trying to install the rpm but you don't have the dependencies installed.

Use this command to pull the dependencies along with installing the package:

zypper install Downloads/code-1.33.1-1554971173.el7.x86_64.rpm

You can also install it using the directions here: https://code.visualstudio.com/docs/setup/linux

sudo rpm --import https://packages.microsoft.com/keys/microsoft.asc

sudo sh -c 'echo -e "[code]\nname=Visual Studio Code\nbaseurl=https://packages.microsoft.com/yumrepos/vscode\nenabled=1\ntype=rpm-md\ngpgcheck=1\ngpgkey=https://packages.microsoft.com/keys/microsoft.asc" > /etc/zypp/repos.d/vscode.repo'

sudo zypper refresh

sudo zypper install code

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .