2

I have an internal drive nvme0 with partitions for windows and ubuntu budgie 19.04. Now I installed KDE neon to my external SSD. This made it so that I can only get into grub when I have my external drive connected. When I reconnect it and reboot, it seems to work again. I would love to know how to enable bootloader to just work from the internal drive. The external drive is small but it isnt practical to take it everywhere with me just to boot off it.

2
  • Are you using legacy BIOS or UEFI? In either case, you should install grub onto your internal disk and config your BIOS to boot from the internal disk. Apr 28, 2019 at 15:18
  • I am using UEFI, and grub was installed onto my internal drive before adding KDE neon to my external drive. The installer only said it was changing my sda device which is the external one so I dont know why it stopped working. Did it make changes to my boot partition on my main drive without my permission? Apr 28, 2019 at 15:58

1 Answer 1

2

This should be relatively simple to fix. The installer has in some way replaced the UEFI Grub bootloader for Ubuntu. This might have installed a new boot loader side by side with your existing Grub, or it might have completely replaced it.

Your new bootloader / bootloader config has is setup to load its full config from your external drive (from /boot/grub). So your task is to revert the configuration.

First of, boot into Ubuntu (with the drive plugged in). Then as root:

sudo grub-install
sudo update-grub

If this doesn't fix the problem then you will also need to check in your BIOS to see if a new bootloader has been installed side by side. If so you should be able to select your old bootloader in your BIOS's boot settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .