1

I have my old ThinkPad X201 with one specific problem: both Shift keys on the main keyboard are not working.

The issue appeared when the provious owner reinstalled Windows. I've installed Manjaro 18.04, but the problem persisted.

External keyboards work just fine (actually, I'm typing from one right now), but the onboard one doesn't.

I've tried showkey, but got no shift keycode. I've tried xev, but got no shift output whatsoever. I've digged through the BIOS to see anything that could affect such behaviour, but still got nothing. Now I don't know what may be the cause of this problem, and how to solve it.

One of the possible solutions may be reinstalling the BIOS, but to me that seems risky (haven't done it and don't know how to do that yet), thus any other solution would be preferred.

UPDATE

I've tried to reflash the BIOS using geteltorito (like this instruction), successfully booted into the created bootable USB drive, followed the instructions with no errors, but the Shift keys still don't work. As for EC, I couldn't find any info about how to update/reflash it. Any suggestions on what to do next? Because apart from replacing the keyboard I'm clueless. Or any suggestions where to find help might also be good.

UPDATE 2

I've succesfully downgraded and then updated my BIOS and EC, but Shift keys remained numb at all times. I've removed plastic piece under the Thinkvantage button to see if there was any water damage, but there were no signs of it. So I think my next step would be to manually probe the keyboard ribbon to see if Shift keys make contact at all. If not - then 20 dollar keyboard is my choice, but if yes - then it might be problems with motherboard. Any suggestions on what to do would be appreciated.

UPDATE 3

I've removed my keyboard and probed the contacts to see if shifts even make contact at all. Unfortunately they do, that means that the problem is with the motherboard. fml.

3
  • For a (different) question about rollover, see unix.stackexchange.com/q/268850/5132 .
    – JdeBP
    Apr 27 '19 at 12:38
  • @JdeBP The problem is not with the rollover, because I'm not pressing multiple keys simultaneously, but rather the shift itself. 'showkey' keycodes for caps, alt, ctrl and even fn work perfectly fine, when pressing them individually
    – F. Rosty
    Apr 27 '19 at 12:48
  • I did not say that the problem was rollover. I pointed to a related question about rollover. Remember that there are people other than you who read Q&As.
    – JdeBP
    Apr 27 '19 at 13:02
0

The Embedded Controller update (*.FL2) should have been applied with the bios update (*.FL1) and contains the configuration for the keyboard.

You can flash it manually from a USB thumb drive using a "dos diskette" and the phlash16 utility, but you could also do this to verify the ECP has been updated:

  1. Go to bios setup, write down bios/ecp version.
  2. Downgrade bios/ecp with a lower version like 1.39 (6QET69WW) (scroll down).
  3. Go to bios setup again, verify the downgrade has been applied.
  4. Reflash with the latest version.
  5. Recheck bios/ecp version in setup.

Also try loading "Setup Defaults" in the bios setup with F9.

Maybe you are lucky and the keybord connector is loose/dirty. You can remove the keyboard and clean the connector/socket with alcohol (isopropanol) and retry.

If you have more than one Thinkpad with the same keyboard connector you can test with a different keyboard. Two weeks ago I used an X61 keyboard on a T530 of a friend (water damage).

More flash methods for linux are described here: https://www.thinkwiki.org/wiki/BIOS_Upgrade

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.