2

I went to check the official repo

 curl -s https://packagecloud.io/install/repositories/AtomEditor/atom/script.deb.sh | sudo bash
Detected operating system as Ubuntu/bionic.
Checking for curl...
Detected curl...
Checking for gpg...
Detected gpg...
Running apt-get update... done.
Installing apt-transport-https... done.
Installing /etc/apt/sources.list.d/AtomEditor_atom.list...done.
Importing packagecloud gpg key... done.
Running apt-get update... done.

Next step is to update

Err:22 https://packagecloud.io/AtomEditor/atom/ubuntu bionic Release    
  404  Not Found [IP: 54.241.144.200 443]

I tried Rui's suggestions

root@miki:/etc/apt/sources.list.d# mv AtomEditor_atom.list deb [arch=amd64] https://packagecloud.io/AtomEditor/atom/any/ any main

It shows

mv: target 'main' is not a directory

How to solve this error?

SOLVED First deleted the file,then

sudo sh -c 'echo "deb [arch=amd64] https://packagecloud.io/AtomEditor/atom/any/ any main" > /etc/apt/sources.list.d/atom.list'
3

The path for the needed repository does not seems to exist on the remote server as APT is configured.

Replace your file /etc/apt/sources.list.d/AtomEditor_atom.list contents with:

deb [arch=amd64] https://packagecloud.io/AtomEditor/atom/any/ any main

After that, run sudo apt update again.

Note: APT repository configuration line taken from Atom's github page.

  • Olha pra meu edit,faz favor. – MikiBelavista Apr 27 at 9:45
  • @MikiBelavista I have seen both edits, it worked then, congrats! – Rui F Ribeiro Apr 27 at 9:57
  • (I edited the answer for clarity) – Rui F Ribeiro Apr 27 at 10:15
  • 1
    it makes sense. – MikiBelavista Apr 27 at 11:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.