I recently installed Windows To Go onto my SD card, which is working fine (when e.g. booting from it using a SD-USB-adapter). Unfortunately my Notebook (Medion Akoya E4253) is not able to boot from it when it's inserted in it's native SD-card slot. When I connect it by an SD-USB-Card adapter everything words just fine.

The problem already occurs when I'm trying to boot from it by my UEFI, because it does not find any bootable SD medium (also tried with Linux on SD, etc). With the adapter, it works.

When I run update-grub it recognizes the SD card and it's bootable content and it adds Windows to the boot menu. But when I try to boot from it, this error occurs:

error: no such device: abc-xyz error: file '/efi/Microsoft/Boot/bootmgfw.efi' not found.

Is there anything I can do so that GRUB will recognize the SD card, or is this due to the UEFI not recognizing it? The UEFI unfortunately does not have any option to fix this. Thanks in advance!

closed as off-topic by Rui F Ribeiro, Fabby, telcoM, Kiwy, Christopher May 2 at 22:14

  • This question does not appear to be about Unix or Linux within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Use Rufus to create Windows-to-go bootable media. – Biswapriyo Apr 26 at 19:04
  • I did. However the SD card is working on Computers on which the UEFI does recognize the SD card, so why should this be related to the Windows 10 installation? – Stefan Wobbe Apr 27 at 6:02
  • 1
    It sounds like the UEFI firmware does not include a driver for the SD-card slot, and so the firmware is not capable of booting any OS at all using that slot. It might be theoretically possible to find (or program) an UEFI firmware-level driver for the SD-card slot, and load it from either the internal HDD/SSD or an external USB, and once it's been loaded, proceed to boot Windows with the SD-card slot. But that would be extremely tricky, and there is no guarantee that an UEFI driver even exists for the card slot. – telcoM Apr 28 at 21:21

The USB-SDcard adaptor identified itself to the system as a USB mass storage, which is supported by your uefi boot. The SDcard slot seems to be directly connected via the MMC port of the controller, which doesn't have a driver in your uefi boot code.

Fortunally, GRUB seems to have the matching driver, but your SDcard is missing the bootmgfw.efi file. You can copy it from the Windows\Boot\Efi folder of a running windows installation.

Not the answer you're looking for? Browse other questions tagged or ask your own question.