0

I recently installed a fresh copy of Manjaro Architect and didn't change too much in the setup. I'm using the i3 window manager and the Linux 41.9 LTS kernel. When trying to set up my usual programs, I tried getting Visual Studio Code with

sudo pacman -S code

which worked, but whenever I tried to launch it, nothing comes up, but I know the process is running since my CPU usage spikes to 100% and I can see it in htop. The strange part about this is that when I hover over certain areas on my screen, my mouse changes as if I were hovering over the actual elements in the application, but nothing's there. I think it is fully functional but just not visible because I even opened a file from the command line in the editor and wrote some gibberish and hit CTRL+S, and it did write to the file on the disk.

I also ran code with the --verbose flag to see what was happening. This is just a snippet of what I got:

[1870:0426/131710.793324:ERROR:gles2_cmd_decoder.cc(5637)] Error: 5 for Command kBufferData
[1870:0426/131710.795932:ERROR:gles2_cmd_decoder.cc(4548)]   GLES2DecoderImpl: Trying to make lost context current.
[1870:0426/131710.796308:ERROR:buffer_manager.cc(452)] [.DisplayCompositor-0x2e8af8e72c00]GL ERROR :GL_OUT_OF_MEMORY : glBufferData: <- error from previous GL command
[1870:0426/131710.796478:ERROR:gles2_cmd_decoder.cc(5637)] Error: 5 for Command kBufferData
[1870:0426/131710.800105:ERROR:gles2_cmd_decoder.cc(4548)]   GLES2DecoderImpl: Trying to make lost context current.
[1870:0426/131710.803579:ERROR:gles2_cmd_decoder.cc(4548)]   GLES2DecoderImpl: Trying to make lost context current.
[1870:0426/131710.803986:ERROR:gles2_cmd_decoder.cc(4548)]   GLES2DecoderImpl: Trying to make lost context current.
[1870:0426/131710.804147:WARNING:ipc_message_attachment_set.cc(49)] MessageAttachmentSet destroyed with unconsumed attachments: 0/1
[1870:0426/131710.805010:WARNING:ipc_message_attachment_set.cc(49)] MessageAttachmentSet destroyed with unconsumed attachments: 0/1
[1870:0426/131710.817876:ERROR:gles2_cmd_decoder.cc(2643)] [GroupMarkerNotSet(crbug.com/242999)!:A04E9083460C0000]GL ERROR :GL_OUT_OF_MEMORY : BackFramebuffer::Create: <- error from previous GL command

That same error was repeating nonstop throughout the log. Thinking that it was just an error with Visual Studio Code, I tried downloading Atom. Atom also uses Electron as its base and I had a similar issue with it. Same with Discord.

0

The issue ending up being the graphics driver that I had installed. When installing Manjaro Architect, I opted for free drivers, not proprietary ones. I just tried installing the proprietary NVIDIA driver and relaunching code and it ended up working. The command I used to install the proprietary driver was:

sudo mhwd -a pci nonfree 0300

*mhwd is a Manjaro-specific command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.