I'm using xubuntu 18.04(Linux 4.15.0-48-generic x86_64 )(buildd@lgw01-amd64-036) (gcc version 7.3.0 (Ubuntu 7.3.0-16ubuntu3)) #51-Ubuntu SMP), after installing anki as shown on anki's web:

$ tar xjf Downloads/anki-2.1.12-amd64.tar.bz2
$ cd anki-2.1.12-linux-amd64
$ sudo make install

I got this message when I run anki:

qt: Could not load the Qt platform plugin "xcb" in "" even though it was found. qt: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.

[1] 3022 abort (core dumped) anki

Even after reinstalling it, or restarting my machine.

  • Is that the only Qt application that fails? What about the demo programs of Qt (in the qtbase5-examples package)? – Toby Speight Oct 2 '19 at 13:39

With Xubuntu 18.04, you have (2) options to install anki without going through the trouble of compiling it yourself:

  1. From the Ubuntu repos: sudo apt install anki (version 2.1.0)
  2. From Flatpak: flatpak install flathub net.ankiweb.Anki (version 2.1.13)
|improve this answer|||||

Try: Going to your platforms directory and performing, ldd libqxcb.so. Make sure that all the dependencys listed are installed and that they are in your collection of shared librarys. If not install or place them in your shared libs.

|improve this answer|||||

Try reinstalling libxcb:

sudo apt purge libxcb
sudo apt install libxcb 

If the package is not found use this:

sudo apt purge libxcb1
sudo apt install libxcb1

More info about the packages: https://packages.ubuntu.com/source/bionic/libxcb

Also, post the output of ldd /usr/lib/qt/plugins/platforms/libqxcb.so

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.