1

I got a Lenovo Thinkpad X1 and have been trying to boot Arch from an ISO that I burned onto a 4 GB USB stick.

The ISO image is burned correctly and is not corrupted. The partition created on my SSD are:

/dev/nvme0n1p1     8G      swap
/dev/nvme0n1p2     469G    ext4

I've tried out the following:

Originally, timedatectl set-ntp true did not retrieve the right timezone so I manually set it to Europe/Zurich which works. I checked with timedatectl status and it is okay now.

I checked that the ip link is up and running by pinging archlinux.org (or whatever other website).

I followed the Installation guide and instructions I found on some community help pages to run:

  1. dirmngr < /dev/null This creates the /root/.gnupg directory and cache.

  2. pacman-key --init This gives me -

gpg: Generating pacman keyring master key
gpg: agent_genkey failed: No such file or directory
gpg: key generation failed: No such file or directory
Updating trust database
No need for a trustdb check

Note: I have also tried to either edit pacman.conf to provide a --gpgdir as /root/.gnupg after generating a gpg key using gpg2 --gen-key Successfully generated my own gpg key and pacman-init did create the secring using this directory as home. I tried to update GPGDir in pacman.conf to point to /root/.gnupg but did not notice any difference in the outcome.

  1. `pacman-init --populate archlinux This command usually completes without error when I do not generate my own gpg key. If I do follow my own keygen and then run pacman-init and populate the error is as follows:
Locally signing key <alphanumeric keyname>
ERROR: <alphanumeric keyname> could not be locally signed.

This message repeats for all the keys (6 times).

However, if I run pacman-init without generating my own gpg key (but after running dirmngr < /dev/null) then the populate proceeds smoothly. (remember that in this case the pacman-key --init had failed to migrate the secring).

  1. pacman-key --refresh-keys runs into an (expected?) error of -
Refreshing 112 keys from hkps://hkps.pool.sks-keyservers.net
A specified local key could not be refreshed from the keyserver.

I have also run gpg --refresh-keys between step 1 and 2 which gives the same error. Is this expected?

  1. pacman -Syu (also -Sy -Syyuu) same error -
error: GPGME error: No data
error: failed to update core, community, extra (invalid or corrupted database (PGP signature))
error: failed to synchronize all databases
  1. pacstrap /mnt base
Creating install root at /mnt
Installing packages to /mnt
error: GPGME error: No data
failed to update core, community, extra (invalid or corrupted database (PGP signature))
error: failed to synchronize all databases

I assume it runs pacman -S first so it is logical for it to throw the exact same error.

To solve this, I cleared the cache with pacman -Scc and also tried to replace the *.db files in var/lib/pacman/sync with those from ftp://mirror.csclub.uwaterloo.ca/archlinux/community/os/x86_64/community.db and ftp://mirror.csclub.uwaterloo.ca/archlinux/extra/os/x86_64/extra.db but the wget command hangs and does not complete. Not sure why this is the case.

I have also edited the pacman.conf to set SigLevel = TrustAll Optional or simply to TrustAll which seems, I believe the most basic/no verification.

I have been through the Installation Guide and the Wiki and retried installation from scratch twice. I have also solicited help from friends who have installed and have been working with Arch Linux but to no avail.

Update: I followed this Arch Installation Question and basically "sudo-ed" the init, populate, and sync commands. I also updated my mirrorlist to point to (only) some German servers.

The init and populate still failed with errors. But the sync worked (sudo pacman -Syy). However, when I try sudo pacman -Syyu it fails with error: unrecognized archive format for the *.db files. Not sure what I did wrong but will retry from scratch and update this post.

I am guessing I should change up the mirrors because that seems to be an issue. Then I need to re-run the sync (do I also need to re-init and repopulate the keys?).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.