0

I have a collection of a dozen directories which are all separate working copies of different svn repos. They are configured the same way on all my machines so I can work on any of them at any time. I'm alone in this: no-one else uses them, and they all use the same credentials as they're all in-house. All the working copies were created with svn --username=aaa --password=bbb co http://xxxx/svn/yyyy . on each machine.

I work in most of them most days, and periodically invoke a shell script which loops through them all and does an svn up and an svn ci -m "stuff" in each of them.

This is all under Linux Mint 19 on all machines (and has been running fine under previous releases for years) but on one machine (HP Envy laptop) the script returns the same error for each one (names masked):

svn: E170013: Unable to connect to a repository at URL 'http://xxxx/svn/yyyy'
svn: E215004: No more credentials or we tried too many times.
Authentication failed

However, if I issue an svn up manually in any of the directories, it works (ie it knows the credentials)…and then running the script works fine, and everything is synch'd.

I don't get prompted for any keychain stuff (nor am I aware that any keychain is in use). As the script works fine without the manual intervention on all my other machines, I'd appreciate any pointers as to where I should look for this particular one not working.

0

I don't know Mint (good), but I'll check at least two things

  • Does script execued under the same user, as user under which you running svn up
  • Can script connect (technically) to repo without user's intervention and how many times it tries to do it (expected result: 1 time)

You can also add hardcoded credentials into svn up as last resort

  • yes, everything is done under my userid – Peter Flynn Apr 25 at 20:20
  • Once. The script runs correctly after I use svn up manually. Otherwise it issues the errors messages as described. – Peter Flynn Apr 25 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.