1

I am getting the below error message

Could not connect to host 127.0.0.1: Connection refused.

on ktorrent on slackware 13.1 and the torrents cannot start.

I tried to reconfigure the ktorrent prefernces, I flushed the iptables but still no success.

When I log in via root and start ktorrent, then the torrents start and no error message is displayed, but when I am logged in as a regular user then the torrents don't work.

How can I solve it?

4
  • 2
    Is there any details on which port it tries to connect on your localhost? Is it below 1024 (reserved for superuser)?
    – alex
    Dec 25, 2010 at 19:02
  • No it's not below 1024.
    – muteto
    Dec 26, 2010 at 16:28
  • 1
    @muteto output of iptables -L -nv? also do you have a session of ktorrent running as root? or any other user concurrently? Dec 26, 2010 at 22:05
  • It doesn't show any rule, like i said i flushed the iptables, and no, i don't have a session of ktorrent running as root.
    – muteto
    Dec 27, 2010 at 20:57

1 Answer 1

1

After you started it with root, it changed permissions of some files and temporary folders. After that, it's not possible to start it with normal user anymore.

You can try reinstalling it, or running for example

strace ktorrent

to get error messages. Also, you should check ktorrent logs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy