-1

I got a Suse system with a apache2 web server. When i try to start apache i get a error, when i ask the status of apache2 i get the information that httpd not run. So now i try to start httpd

systemctl start httpd

but that not works, so i ask

systemctl status httpd

The result is:

httpd.service
Loaded: not-found (Reason: No such file or directory)
Active: inactive (dead)

How can i start httpd corecly ?

closed as too broad by Ipor Sircer, Fabby, Michael Homer, Rui F Ribeiro, Kiwy Apr 29 at 9:16

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    Please update your question with the complete output from systemctl status httpd. You should also review the system logs for specific messages that are relevant and include them as well. – 0xSheepdog Apr 23 at 14:58
  • 1
    And if you really want to blow 0xSheepdog's mind, you can put the output of head -n 11 /usr/share/doc/packages/apache2/README-instances.txt in the question too. (-: – JdeBP Apr 23 at 15:55
1

JdeBP commented in this direction, so I thought I'd flesh it out into an Answer.

The SUSE README for Apache says, in part:

Dear System Administrator,

SUSE Apache package comes with the possibility to run more instances of Apache process on one system.

As always,

sytemctl start apache2

activates default instance of the server, which expects sysconfig setting in /etc/sysconfig/apache2. If this file is not present, or APACHE_HTTPD_CONF in there is not set, then it requires /etc/apache2/httpd.conf.

... which seems to point out the error; you've attempted to start a unit named "httpd" when the unit is actually named "apache2". That also lines up with the evidence you saw, which said:

Reason: No such file or directory

... since there is no httpd.service file.

  • It's the same for Debian. Shh! Don't tell people. Also bear in mind what the questioner will have seen resulting from that head command. (-: – JdeBP Apr 23 at 17:03
  • Sounds like it'll result in No such file or directory at this point, but hopefully this Answer will serve some other long-tail purpose. – Jeff Schaller Apr 23 at 17:16
  • When i ask for already running apache2 processes with ps -aux | grep apache2 i get no output. Also i uninstalled and installed again. But still the same error – Marius Illmann Apr 24 at 8:30
  • okay, i fixed it. I uninstalled apache2 not totaly. after i . also delete /etc/sysconfig/apache2 and installed agan it works. – Marius Illmann Apr 24 at 8:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.