0

This question already has an answer here:

I am working on a Debian-based Dragon Board (410C) system. The system will produce a touch screen that triggers some functions of a car. I am trying to hide the mouse cursor in my application. Connected to my device with SSH and tried lots of stuff. But cursor is always there. I think that maybe a graphical mouse cursor image (not an actual cursor) by the interface may cause the fail.

I tried such of ways to hide the cursor as installing application 'unclutter' and running it at startup file (.myxinitrc) with the command 'unclutter -idle 0.1 -root' and ended up with a working command, but no visual changes at all, this command hides the mouse cursor on a Debian-based Ubuntu system, I also tried to write option '.myxinit – -nocursor' when I am calling my xinitrc file at the startup.

when I enter the command

unclutter -idle 0 -root

it gives an error like “unclutter could not open display”. If I change the command like

unclutter -idle 0 -root -display :0

it runs the command (it moves to the next line and idles until I press ^c) but still nothing changes. When I run the same command on my Ubuntu, it hides the cursor.

The system runs my service called “mycarui” at startup. Not a linux interface or anything. It has only guided access to my service as default.

marked as duplicate by Ipor Sircer, Mr Shunz, Renan, Stephen Harris, Sparhawk Apr 26 at 2:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

migrated from serverfault.com Apr 23 at 13:15

This question came from our site for system and network administrators.

1

This might be a bit of a work around, but coul dyou just get a blank cursor file and assign that as your cursor. It will still be there, just invisible.

  • Sounds brilliant. But -sorry for being noobish- do you know how do i change the cursor by its file on a debian? – xtcuser Apr 23 at 15:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.