0

I have a:

Lenovo Y520-15KIBA CPU Intel i5 with GPU AMD Radeon RX560

linux kernel 4.20.47-custom (with bloobs of new firmware 1.175) DRM is 3.27.0

also kernel 4.17-generic is in the grub

I want to know how and if it is possible to setup a 10-amdgpu.conf file in a manner that my amdgpu is not showing errors like or at least give some glxgears output better than 1 FPS:

dmesg | grep amdgpu

[    1.558902] [drm] amdgpu kernel modesetting enabled.
[    1.559324] amdgpu 0000:01:00.0: enabling device (0000 -> 0003)
[    1.598721] amdgpu 0000:01:00.0: VRAM: 2048M 0x000000F400000000 - 0x000000F47FFFFFFF (2048M used)
[    1.598724] amdgpu 0000:01:00.0: GART: 256M 0x000000FF00000000 - 0x000000FF0FFFFFFF
[    1.598959] [drm] amdgpu: 2048M of VRAM memory ready
[    1.598961] [drm] amdgpu: 3072M of GTT memory ready.
[    1.677073] [drm:dc_create [amdgpu]] *ERROR* DC: Number of connectors is zero!
[    1.923112] [drm] Initialized amdgpu 3.27.0 20150101 for 0000:01:00.0 on minor 1
[   12.285945] amdgpu 0000:01:00.0: GPU pci config reset

DRI_PRIME=0 | grep -B

Vendor: Intel Open Source Technology Center (0x8086)
Device: Mesa DRI Intel(R) HD Graphics 630 (Kaby Lake GT2)  (0x591b)
Version: 18.2.8

DRI_PRIME=1 | grep -B

Vendor: X.Org (0x1002)
Device: Radeon RX 560 Series (POLARIS11, DRM 3.27.0, 4.20.17-custom, LLVM 7

Testing my card with

DRI_PRIME=1 glxgears

gives me 0.7 (sic!) frames per second and causes system freeze

therefore I think the card is not working properly

i have tried 2019 April with:

  • drivers from amd ./amdgpu-install + pro on LMDE3, Linux Mint 19 ubuntu 18.04.1 18.04.2 (amd version 17.40, 18.x and 19.10) (each fresh install)
  • mesa ppa oibaf Mint 19 Ubunut 18
  • mesa ppa miguel Mint 19 (install failed) and Ubuntu 18
  • somehow I was able to run mesa 19 on ubuntu 18 did not make a difference in glxgears
  • custom kernel build 4.20. 5.0.6 5.0.8 5.0.9 LMDE3
  • rocm on linux mint19 -I always did a video group usermod *see below
  • I tried various xorg.confs
  • various vulkan installs and mesa-opencl-icd

*

sudo usermod -a -G video $LOGNAME

The standard configuration looks like:

sudo pico /usr/share/X11/xorg.conf.d/10-amdgpu.conf

Section "OutputClass"
    Identifier "AMDgpu"
    MatchDriver "amdgpu"
    Driver "amdgpu"
EndSection

and is working out.

Section "Device"

is not working out (gives a black screen) and I want to know why. I hope to get better performance, when using "Device" and adding it to "Screen Section"

0

long story short: Updating to linux mint 20 Ulyana (cinnamon) helped me out of my misery.

dmesg|grep amdgpu

[ 0.905200] [drm] amdgpu kernel modesetting enabled.
[ 0.905639] amdgpu 0000:01:00.0: remove_conflicting_pci_framebuffers: bar 0: 0x90000000 -> 0x9fffffff
[ 0.905642] amdgpu 0000:01:00.0: remove_conflicting_pci_framebuffers: bar 2: 0xa0000000 -> 0xa01fffff
[ 0.905644] amdgpu 0000:01:00.0: remove_conflicting_pci_framebuffers: bar 5: 0xa2400000 -> 0xa243ffff
[ 0.905653] amdgpu 0000:01:00.0: enabling device (0000 -> 0003)
[ 0.940761] amdgpu 0000:01:00.0: VRAM:2048M 0x000000F400000000 - 0x000000F47FFFFFFF (2048M)
[ 0.940764] amdgpu 0000:01:00.0: GART: 256M 0x000000FF00000000 - 0x000000FF0FFFFFFF
[ 0.941049] [drm] amdgpu: 2048M of VRAM memory ready
[ 0.941052] [drm] amdgpu: 3072M of GTT memory ready.
[ 0.943880] amdgpu: [powerplay] hwmgr_sw_init smu backed is polaris10_smu
[ 1.277116] [drm] Initialized amdgpu 3.35.0 20150101 for 0000:01:00.0 on minor 1
[ 11.618382] amdgpu 0000:01:00.0: GPU pci config reset

DRI_PRIME=1 glxgears

gives me 60 FPS as is my monitor refresh rate. Which tells me it is working fine now.

| improve this answer | |
  • Case closed with linux mint update. – kamino Nov 27 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.