0

I am building a kiosk machine with Debian 9.8 and XFCE4.

Everything is done except disabling right click in Desktop.

Tried xmodmap -e 'pointer = 1 2 0 4 5 6 7 8 9'; however, it disabled right click every where, i.e., in application too.

I need to disable the right click on desktop & icons.

0

If you want to disable the right click menu in xfdesktop you'll need to compile it with ./configure --disable-desktop-menu

also you can try this. If you're using Xfce 4.10, you may try the following:

In Settings > Desktop > Menus uncheck Show applications on right click and perhaps uncheck Show window list on middle click.

If in addition you go to Settings > Desktop > Icons and select type: None or Minimized, then this should pretty much disable all interaction with the desktop.

  • You mean only compile only xfdesktop xfdesktop? Sorry, I am new to this. – Emmanual Apr 22 at 14:03
  • sorry i didn't get what you said properly. yes compile xfdesktop again. you don't need other xfce packages like xfce4-session. – Rasool Ziafaty Apr 22 at 17:18
  • Thanks.. I will try that. – Emmanual Apr 24 at 13:48
  • let me know if my answer was helpful. and don't forget to accept my answer as correct answer if it works. – Rasool Ziafaty Apr 24 at 14:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.