1

So I've got Debian with GNOME on my Clevo N85_87HP6 laptop with a GTX1060 video display adapter plus Intel's integrated GPU. Pressing fn + f8/f9doesn't change my screen's brightness. I've tried using

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi = acpi_backlight=intel"

and a few other lines like that in my grub file, including a tip to add i915.enable_dpcd_backlight, but none helped.

Commands like

 # tee /sys/class/backlight/intel_backlight/brightness <<< 100 

and xbacklight -dec 10 work but I'm unable to make my keys work. I've been digging around the internet since yesterday but I didn't found any solution to my problem. I've also noticed with xev that when I press fn + f8/f9 nothing is detected, but when I press fn + f5/f6 that are keys responsible for sound volume it detects them normally.

I've also tried making a 20-intel.conf file in /usr/share/X11/xorg.conf.d containing

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"
EndSection

which did not work.

How to make those keys work; is it a problem with acpi?

  • 2
    Have you tried kernel parameter i915.enable_dpcd_backlight (from here)? – Freddy Apr 21 at 13:40
  • 1
    @Freddy tried it now, no changes. – Ecuros Apr 21 at 16:47
  • It's the Clevo N85_87HP6 – Ecuros Apr 23 at 10:12
  • Your laptop is discontinued by Clevo clevo.com.tw/clevo_pro.asp?lang=en and there's no Linux driver support from Sager sagernotebook.com/drivers.php?cat=697 – K7AAY Apr 23 at 21:38
  • Does that mean there's no way to control the brightness with those keys? This seems very strange to me... – Ecuros Apr 24 at 11:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.