1

I have an old Lexmark 1100 printer (parallel port LPT1) that is currently working flawlessly on Windows 98. I've tried to make it work on Debian LXDE (fresh new install), live Debian Xfce and live Mint Xfce but, unfortunately, none worked. Basically, I've followed the OpenPrinting installation steps:

  1. apt install lsb
  2. search for the OpenPrinting Lexmark 1100 driver
  3. download x86 32bit driver for Debian
  4. dpkg -i openprinting-lm1100_1.0.2a-6lsb3.2_i386.deb
  5. add printer on CUPS

Note: In Mint Xfce I've also double clicked on openprinting-lm1100_1.0.2a-6lsb3.2_i386.deb (LXDE doesn't allow that) and let the package manager do the rest automatically.

Unfortunately, the printer never showed any sign of life during the test pages printing. Sometimes, depending on the type of installation, there was an error message ('filter fail') or no error message at all.

To rule out potential driver issues with Debian, especially with a minimal installation, I tested it with Mint. Mint seems to have more drivers and packages, which might make it work with more hardware. Since Mint also failed, this would seem to rule out a distro-specific issue.

Driver Compatibility with CUPS

The driver information page specifically lists my printer model, so it seems to be the correct one, although ancient. One possibility is that the driver isn't compatible with current versions of CUPS.

Question

How do I get CUPS to use the printer driver, or more generally, how do I get my printer to work with Linux?

My objective is to be able to use the printer with Linux regardless of the distro. So if the problem actually is distro-based rather than a CUPS issue and another distro is able to support it, that would be fine.


Additional Notes

Parallel Port LPT1
I'm not sure how to verify whether the Debian installation includes a parallel port driver. However, I surmise that it does:

  1. CUPS only allow to install the printer after plugging it on LPT1. After that it correctly show there is something on LPT1 although it cannot recognize which printer (probably it predates the plug and play era).
  2. I've already installed another device on LPT1 and it worked nice (Epson Stylus Color 480SX).

Therefore, considering that Debian is seeing a printer on the port, and especially that another printer worked on LPT1, it seems safe to assume that it's got a parallel port driver.

 

Notebook Specifications
Toshiba Satellite 1135-S1553

  • Intel® Celeron® 4 processor at 2.20GHz
  • Intel 852GM Chipset
  • 1Gb RAM
  • 32MB internal Integrated Intel® 852GM video memory

 

Debian Version

  • Small CDs
  • debian-9.8.0-i386-netinst.iso
  • Tasksel:
    (  ) Debian desktop environment
    (  ) ... GNOME
    (  ) ... Xfce
    (  ) ... KDE
    (  ) ... Cinnamon
    (  ) ... MATE
    (X) ... LXDE
    (  ) web server
    (X) print server
    (  ) SSH server
    (  ) standard system utilities

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.