2

I am using Manjaro for the support for kdenlive alongside playing games.

The way my two monitors were set up on windows 10 originally was having a DVI cable for my old monitor plugged into my motherboard to let the onboard graphics deal with that one, and then use my GTX 1070 for handling my newer, 144hz monitor over displayport. First time I installed, my old monitor wasn't recognized, but my displayport one was, so after some tinkering with other things, I went and looked at the Displays app and checked for other possible displays, it said that another existed over "HDMI2" despite it clearly being over DVI, but whatever, I just enabled the display.

Then issues immediately popped up where my old monitor turned on, but was a black screen, then I could move my mouse over to it, which did show up on the black void, but then garbled graphics would appear on the top of the screen.

Eventually after a reinstall of Manjaro, I decided to go in and not have my DVI cable plugged in during the installation process, then plug it in afterwards and then select my old monitor after all of that, which did work and it does show up with actual graphics and functions correct... until I restart the computer, to which Manjaro then decides that my displayport monitor now will not function, the splash screen from my motherboard boot sequence stays on my displayport monitor and only my DVI monitor is recognized, no matter how many times I plug the displayport cable into different slots. In fact, it only works with the slot I initially plugged it into, which then simply shows the motherboard splash again, and still isn't recognized in Manjaro.

My specs:

i7-4790k CPU

GTX 1070 GPU

16gbs of DDR3 ram

Gigabyte z97x Gaming 7 motherboard

Manjaro KDE 64-bit

No overclocking of any kind have been done on either the CPU or GPU throughout this situation.

Edit 2: I've just tried a thing with the DVI cable and plugged it into my GPU to see if it would do anything, the motherboard splash showed up on the DVI monitor this time... and my displayport monitor showed nothing, so it seems like Manjaro's just not liking my GPU currently.

Edit 3: At the request of user kemotep, I've run some commands and here's the output:

[user@user-pc ~]$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller (rev 06)
01:00.0 VGA compatible controller: NVIDIA Corporation GP104 [GeForce GTX 1070] (rev a1)

[user@user-pc ~]$ lsmod | grep "kms\|drm"
drm_kms_helper        208896  1 i915
drm                   495616  21 drm_kms_helper,i915
agpgart                49152  2 intel_gtt,drm
syscopyarea            16384  1 drm_kms_helper
sysfillrect            16384  1 drm_kms_helper
sysimgblt              16384  1 drm_kms_helper
fb_sys_fops            16384  1 drm_kms_helper

[user@user-pc ~]$ find /dev -group video
/dev/fb1
/dev/dri/card0
/dev/fb0

[user@user-pc ~]$ cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 root=UUID=9e897b2b-7796-4f0a-8813-07044c3f397c rw quiet

[user@user-pc ~]$ find /etc/modprobe.d/
/etc/modprobe.d/
/etc/modprobe.d/mhwd-bbswitch.conf
/etc/modprobe.d/mhwd-gpu.conf
/etc/modprobe.d/mhwd-nvidia.conf

[user@user-pc ~]$ cat /etc/modprobe.d/*kms*
cat: '/etc/modprobe.d/*kms*': No such file or directory

[user@user-pc ~]$ ls /etc/X11/xorg.conf
ls: cannot access '/etc/X11/xorg.conf': No such file or directory

[user@user-pc ~]$ glxinfo | grep -i "vendor\|rendering"
direct rendering: Yes
server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
    Vendor: Intel Open Source Technology Center (0x8086)
OpenGL vendor string: Intel Open Source Technology Center

[user@user-pc ~]$ grep LoadModule /var/log/Xorg.0.log
[     4.622] (II) LoadModule: "glx"
[     4.636] (II) LoadModule: "intel"
[     4.644] (II) LoadModule: "dri3"
[     4.644] (II) LoadModule: "dri2"
[     4.644] (II) LoadModule: "present"
[     4.759] (II) LoadModule: "libinput"

(note, I edited the output to "user-pc" for privacy reasons)

  • Welcome to the the Unix and Linux stack exchange! Please review the Help Center to get information on how to best post to the site. Take the Tour if you are not familiar with how this site works. To get to your question, this setup is not supported out of the box. You will need to go into BIOS and make sure that your graphics card and onboard graphics are both enabled. We will also need to know what drivers you are using. Please edit your post to include the output of these commands – kemotep Apr 19 at 15:51
  • @kemotep Sorry for the extremely late response, I've updated the post to include these commands – Zen Apr 19 at 16:51
  • @kemotep as for the drivers, I've tried installing and uninstalling all applicable graphics drivers from the hardware configuration menu and nothing changed :P And as for bios and onboard graphics, well, again, my setup did work until I restarted the computer, and I've run this setup on windows 10 for a long while now so I'm very confused. – Zen Apr 19 at 16:55
  • please try to format the output as specified here Thank you. – kemotep Apr 19 at 16:57
  • @kemotep ah, my bad, I've fixed it :) – Zen Apr 19 at 16:59
0

After this seemingly went nowhere, I realized that manjaro has its own forums which I honestly should have gone to first

if you wish to read the whole scenario and how I came to my solution: https://forum.manjaro.org/t/multi-monitor-setup-acting-weird/83906

tl;dr I uninstalled and completely removed bumblebee from my drivers using mhwd, installed the video-nvidia driver in mhwd, and then deleted the /etc/X11/xorg.conf.d/90-mhwd.conf file that generated after video-nvidia fully finished installing. After doing that, I rebooted and both my monitors were working perfectly and I was able to game with performance that made sense for my GTX 1070 running native linux ports of Portal 2 and CSGO.

  • Turns out I can't set my own answer as the solution for another 2 days :P I also can't manually set this question to being solved either, welp ¯_(ツ)_/¯ – Zen Apr 20 at 0:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.