0

Usually I find a way around, but I don't understand what is the problem here:

darknmy@pop-os:~$ sudo apt install pop-desktop

Reading package lists... Done

Building dependency tree

Reading state information... Done

pop-desktop is already the newest version (1.2.12~1543260606~18.10~8385858).

0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

1 not fully installed or removed.

After this operation, 0 B of additional disk space will be used.

Do you want to continue? [Y/n] y

Setting up initramfs-tools (0.131ubuntu15.1pop2) ...

update-initramfs: deferring update (trigger activated)

Processing triggers for initramfs-tools (0.131ubuntu15.1pop2) ...

update-initramfs: Generating /boot/initrd.img-4.18.0-17-generic

cryptsetup: WARNING: Resume target cryptswap uses a key file

kernelstub.Config : INFO Looking for configuration...

Traceback (most recent call last):

File "/usr/bin/kernelstub", line 244, in <module>

main()

File "/usr/bin/kernelstub", line 241, in main

kernelstub.main(args)

File "/usr/lib/python3/dist-packages/kernelstub/application.py", line 267, in main

installer = Installer.Installer(nvram, opsys, drive)

File "/usr/lib/python3/dist-packages/kernelstub/installer.py", line 55, in __init__

os.makedirs(self.loader_dir)

File "/usr/lib/python3.6/os.py", line 220, in makedirs

mkdir(name, mode)

OSError: [Errno 5] Input/output error: '/boot/efi/loader'

run-parts: /etc/initramfs/post-update.d//zz-kernelstub exited with return code 1

dpkg: error processing package initramfs-tools (--configure):

installed initramfs-tools package post-installation script subprocess returned error exit status 1

Errors were encountered while processing:

initramfs-tools

E: Sub-process /usr/bin/dpkg returned an error code (1)

darknmy@pop-os:~$
  • This line: pop-desktop is already the newest version (1.2.12~1543260606~18.10~8385858) indicates that pop-desktop is already installed. Your error is that apt has detected the package initramfs-tools is not fully installed. Attempts to fully install initramfs-tools are resulting in an error: OSError: [Errno 5] Input/output error: '/boot/efi/loader' when attempting to make the directory. Without additional information, that is about all I can tell you. – GracefulRestart Apr 18 at 18:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.