0

I am workign on writing a custom live boot usb with Debian as base operating system.

The goal is for this to run on many unpredictable system configurations. Most computers are failing to run startx successfully.

On run I see this:

X.Org X Server 1.20.3
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.9.0-8-amd64 x86_64 Debian
Current Operating System: Linux opswat-dev 4.19.0-4-amd64 #1 SMP Debian 4.19.28-2 (2019-03-15) x86_64
Kernel command line: BOOT_IMAGE=/vmlinuz boot=live persistence quiet nomodeset
Build Date: 25 October 2018  06:15:23PM
xorg-server 2:1.20.3-1 (https://www.debian.org/support) 
Current version of pixman: 0.36.0
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Apr 17 21:22:21 2019
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) 
Fatal server error:
(EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices
(EE) 
(EE) 
Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) 
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

/var/log/Xorg.0.log reports:

[  1410.694] 
X.Org X Server 1.20.3
X Protocol Version 11, Revision 0
[  1410.697] Build Operating System: Linux 4.9.0-8-amd64 x86_64 Debian
[  1410.698] Current Operating System: Linux opswat-dev 4.19.0-4-amd64 #1 SMP Debian 4.19.28-2 (2019-03-15) x86_64
[  1410.698] Kernel command line: BOOT_IMAGE=/vmlinuz boot=live persistence quiet nomodeset
[  1410.700] Build Date: 25 October 2018  06:15:23PM
[  1410.701] xorg-server 2:1.20.3-1 (https://www.debian.org/support) 
[  1410.702] Current version of pixman: 0.36.0
[  1410.703]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[  1410.703] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1410.705] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Apr 17 21:31:09 2019
[  1410.706] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  1410.706] (==) No Layout section.  Using the first Screen section.
[  1410.706] (==) No screen section available. Using defaults.
[  1410.706] (**) |-->Screen "Default Screen Section" (0)
[  1410.706] (**) |   |-->Monitor "<default monitor>"
[  1410.706] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[  1410.706] (==) Automatically adding devices
[  1410.706] (==) Automatically enabling devices
[  1410.706] (==) Automatically adding GPU devices
[  1410.706] (==) Max clients allowed: 256, resource mask: 0x1fffff
[  1410.706] (WW) The directory "/usr/share/fonts/X11/misc" does not exist.
[  1410.706]    Entry deleted from font path.
[  1410.706] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[  1410.706]    Entry deleted from font path.
[  1410.706] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[  1410.706]    Entry deleted from font path.
[  1410.706] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[  1410.706]    Entry deleted from font path.
[  1410.706] (WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
[  1410.706]    Entry deleted from font path.
[  1410.706] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[  1410.706]    Entry deleted from font path.
[  1410.706] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[  1410.706]    Entry deleted from font path.
[  1410.706] (==) FontPath set to:
    built-ins
[  1410.706] (==) ModulePath set to "/usr/lib/xorg/modules"
[  1410.706] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[  1410.706] (II) Loader magic: 0x5608ec5bbe20
[  1410.706] (II) Module ABI versions:
[  1410.706]    X.Org ANSI C Emulation: 0.4
[  1410.706]    X.Org Video Driver: 24.0
[  1410.706]    X.Org XInput driver : 24.1
[  1410.706]    X.Org Server Extension : 10.0
[  1410.707] (++) using VT number 1

[  1410.710] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_31
[  1410.711] (--) PCI:*(0@0:2:0) 8086:0162:1028:0577 rev 9, Mem @ 0xf7800000/4194304, 0xe0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/131072
[  1410.711] (II) LoadModule: "glx"
[  1410.711] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[  1410.712] (II) Module glx: vendor="X.Org Foundation"
[  1410.712]    compiled for 1.20.3, module version = 1.0.0
[  1410.712]    ABI class: X.Org Server Extension, version 10.0
[  1410.712] (==) Matched modesetting as autoconfigured driver 0
[  1410.712] (==) Matched fbdev as autoconfigured driver 1
[  1410.712] (==) Matched vesa as autoconfigured driver 2
[  1410.712] (==) Assigned the driver to the xf86ConfigLayout
[  1410.712] (II) LoadModule: "modesetting"
[  1410.712] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[  1410.712] (II) Module modesetting: vendor="X.Org Foundation"
[  1410.712]    compiled for 1.20.3, module version = 1.20.3
[  1410.712]    Module class: X.Org Video Driver
[  1410.712]    ABI class: X.Org Video Driver, version 24.0
[  1410.712] (II) LoadModule: "fbdev"
[  1410.712] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[  1410.712] (II) Module fbdev: vendor="X.Org Foundation"
[  1410.712]    compiled for 1.20.0, module version = 0.5.0
[  1410.712]    Module class: X.Org Video Driver
[  1410.712]    ABI class: X.Org Video Driver, version 24.0
[  1410.712] (II) LoadModule: "vesa"
[  1410.712] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
[  1410.712] (II) Module vesa: vendor="X.Org Foundation"
[  1410.712]    compiled for 1.20.1, module version = 2.4.0
[  1410.712]    Module class: X.Org Video Driver
[  1410.712]    ABI class: X.Org Video Driver, version 24.0
[  1410.712] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[  1410.712] (II) FBDEV: driver for framebuffer: fbdev
[  1410.712] (II) VESA: driver for VESA chipsets: vesa
[  1410.712] (EE) open /dev/dri/card0: No such file or directory
[  1410.712] (WW) Falling back to old probe method for modesetting
[  1410.712] (EE) open /dev/dri/card0: No such file or directory
[  1410.712] (II) Loading sub module "fbdevhw"
[  1410.712] (II) LoadModule: "fbdevhw"
[  1410.712] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[  1410.712] (II) Module fbdevhw: vendor="X.Org Foundation"
[  1410.712]    compiled for 1.20.3, module version = 0.0.2
[  1410.712]    ABI class: X.Org Video Driver, version 24.0
[  1410.712] (EE) Unable to find a valid framebuffer device
[  1410.712] (WW) Falling back to old probe method for fbdev
[  1410.712] (II) Loading sub module "fbdevhw"
[  1410.712] (II) LoadModule: "fbdevhw"
[  1410.712] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[  1410.712] (II) Module fbdevhw: vendor="X.Org Foundation"
[  1410.712]    compiled for 1.20.3, module version = 0.0.2
[  1410.712]    ABI class: X.Org Video Driver, version 24.0
[  1410.712] (II) FBDEV(2): using default device
[  1410.712] (EE) Screen 0 deleted because of no matching config section.
[  1410.712] (II) UnloadModule: "modesetting"
[  1410.712] (EE) Screen 0 deleted because of no matching config section.
[  1410.712] (II) UnloadModule: "fbdev"
[  1410.713] (II) UnloadSubModule: "fbdevhw"
[  1410.713] (EE) 
Fatal server error:
[  1410.713] (EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices
[  1410.713] (EE) 
[  1410.713] (EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[  1410.713] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  1410.713] (EE) 
[  1410.715] (EE) Server terminated with error (1). Closing log file.

I successfully run startx on a thinkpad t420 laptop. every other machine i've tested has failed. They're all using intel onboard graphics.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.