3

I have a strange (and annoying) problem with my ASUS UX32LA notebook: I suspect that multiple Linux distros (Ubuntu 16.04 and newer major versions using the 4.18.0-17-generic kernel, plus Fedora 28 LiveUSB), somehow breaks BIOS control over fans.

I also tried upgrading Ubuntu to 5.x kernel line. Every attempt was followed by a BIOS re-flash. No attempt brought success.

Why?

  • One day (don't remember when, not using this notebook very often) fans started to work at full speed when using Linux (it was 4.x line kernel).
  • First I though of trying reboot to Windows to see if problem persists. It turned out that indeed fans were still at full speed on Windows.
  • Then I though that it may be a hardware issue. I gave computer to the repair and I was amused when they told me that re-flashing BIOS made fans work properly on Windows (they refused to check on Linux...). No hardware issue.
  • Having computer back I operated Windows for some time (week or so) to see if the issue is gone. It was.
  • After booting into Linux the issue was back as soon as CPU temperature rose enough for the fan to turn on. It turned on to full speed and remained so. After that it's not important if it's Linux or Windows. Fans at full speed.
  • Re-flashing BIOS solves the issue as long as Linux is not booted. On Windows fans work normally.

I don't expect easy answer here, but maybe someone could give me a hint where to start debugging? I found some posts that it may be related to the Differentiated System Description Table...

  • Unfortunately, no additional information on the back of the computer. Output of dmidecode: ASUSTeK COMPUTER INC., product Name: UX32LA, version: 1.0, SKU Number: ASUS-Ultrabook, Family: UX – kaolpr Apr 17 at 21:09
  • Steps to debug: 1) Go through dmesg and /var/log/syslog / journalctl after boot to see if you have any linux kernel modules that detect fans and/or temperature sensors, and or any packages like fancontrol that want to control the fans directly. While you are at that, edit question to indicate what fans and termperature sensors you have, and how they are wired up. 2) If your SM (system management) BIOS is capable of controlling the fans (better check this, unless you want to deal with overheated components), you can disable the Linux fan control (details depend on the package used). – dirkt Apr 18 at 6:57
4

Please check the BIOS setting before installing Linux. The common BIOS optiona for Linux installation is to enable CSM support and select UEFI and legacy support option in the boot device control. Then, in the secure boot option, set the os type to other os.

  • 1
    Enabling CSM solved the issue. I did a stress test (stresss --cpu 4 for 15 minutes), temerature rised, fan RPM as well, but both were in expected range. Thanks a lot! – kaolpr Apr 18 at 9:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.