2

I used to work on linux in a virtual Box and now I'm using a computer with Ubuntu 16.04. I have some ps files I need to convert to pdf and I used to run the command ps2pdf file.ps file.pdf in my previous computer, but now it doesn't work, I get the following error:

/usr/bin/gs: symbol lookup error: /usr/lib/libgs.so.9: undefined symbol: FT_Property_Set

I tried using convert file.ps file.pdf and it doesn't work either, I get the error:

convert.im6: not authorized `sc1.ps' @ error/constitute.c/ReadImage/454.
convert.im6: no images defined `sc.pdf' @ error/convert.c/ConvertImageCommand/3044.
  • 1
    How did you install the ps2pdf utility? It seems like it is missing a library, or has the wrong version of a library. You can check a little further with ldd `which ps2pdf` – ivanivan Apr 17 at 19:16
  • 1
    For the second issue, please refer to this related Q&A: Error during converting jpg to pdf – steeldriver Apr 17 at 19:17
  • I installed Ghostscript and it turned out to be already installed. The ps2pdf command worked just fine with an example ps file that has only images. However, the files I need contain fonts and I think that's where the problem is. – Paula Navarrete Díaz Apr 17 at 19:21
  • 1
    Duplicate of unix.stackexchange.com/questions/387286/… ? – steve Apr 17 at 19:29
  • I followed the steps indicated in the duplicate, but the thing is I don't have the libfreetype.so.6.14.0, and I don't have permission to edit the files anyway. I'm working on the last part, but still, – Paula Navarrete Díaz Apr 17 at 20:32
0

Finally, I followed the steps in the duplicate: How to tell libgs to use another freetype implementation?

However, I didn't have the file libfreetype.so.6.14.0 to replace the original file libfreetype.so.6, so I just deleted it (changed its name) and it worked. Don't know why it worked, but it did. Thanks everyone anyway!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.