0

I want my application to start outside of MonoDevelop. Even after copying all of the DLLs the application asked for when run outside of MonoDevelop (with mono), it still gives an error. The error is this:

Unhandled Exception:
System.TypeInitializationException: The type initializer for 'Gtk.Container' threw an exception. ---> System.DllNotFoundException: gtksharpglue-2
  at (wrapper managed-to-native) Gtk.Container.gtksharp_gtk_container_get_focus_child_offset()
  at Gtk.Container..cctor () [0x00000] in <e8d21baece374fadb4e2b3899720848c>:0 
   --- End of inner exception stack trace ---
  at Gtk.Bin..ctor (System.IntPtr raw) [0x00000] in <e8d21baece374fadb4e2b3899720848c>:0 
  at Gtk.Window..ctor (Gtk.WindowType type) [0x00000] in <e8d21baece374fadb4e2b3899720848c>:0 
  at SteamNightProject.MainWindow..ctor () [0x0000b] in <f203a735b9124b2ca9c13185165bab7c>:0 
  at SteamNightProject.MainClass.Main (System.String[] args) [0x00005] in <f203a735b9124b2ca9c13185165bab7c>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: The type initializer for 'Gtk.Container' threw an exception. ---> System.DllNotFoundException: gtksharpglue-2
  at (wrapper managed-to-native) Gtk.Container.gtksharp_gtk_container_get_focus_child_offset()
  at Gtk.Container..cctor () [0x00000] in <e8d21baece374fadb4e2b3899720848c>:0 
   --- End of inner exception stack trace ---
  at Gtk.Bin..ctor (System.IntPtr raw) [0x00000] in <e8d21baece374fadb4e2b3899720848c>:0 
  at Gtk.Window..ctor (Gtk.WindowType type) [0x00000] in <e8d21baece374fadb4e2b3899720848c>:0 
  at SteamNightProject.MainWindow..ctor () [0x0000b] in <f203a735b9124b2ca9c13185165bab7c>:0 
  at SteamNightProject.MainClass.Main (System.String[] args) [0x00005] in <f203a735b9124b2ca9c13185165bab7c>:0 

I am running Manjaro Linux.

Also if anyone wants to know why I’m not saying too much about this is so that I’m not criticized for saying random things that don’t apply in any way. I will add any information that is requested.

  • If anyone is wondering this isn’t an issue with the code. It runs exactly as expected when run in MonoDevelop. I only get this issue when I try to run it using the mono – Firestar Apr 17 at 2:10
  • Is it on the same machine? – ctrl-alt-delor Apr 17 at 17:00
  • Yes, it is on the same machine. – Firestar Apr 17 at 23:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.