1

I have a wireless adapter (the Panda 300Mbps PAU05) plugged in to a USB port on my Linux Mint 19.1 Tessa desktop computer (my kernel version is 4.15.0-47-generic).

Yesterday, I had it plugged in to the front left USB port on my tower, and when I clicked on the network icon in the taskbar, I was able to click on a menu option called "Create New Wi-Fi Network", and then I could create a Wi-Fi hotspot (with "Mode" being set to "Hotspot").

I didn't really want the adapter on the front of my tower, so I plugged it in to a USB port at the back of the tower today. However, now when I click on the network icon, there are far fewer options, so I can't create the hotspot. I have tried plugging it back into the original USB port and restarting, and I've tried plugging it into other USB ports, but this doesn't solve the problem. All these USB ports are good enough that my keyboard or USB headset can use them.

Yesterday: Yesterday Today: Today

(I got yesterday's screenshot from a screencast I did when trying to set up the hotspot.)

How can I get my OS to show that option again?

When I run lsusb, I notice that the adapter is picked up:

Bus 001 Device 002: ID 148f:5372 Ralink Technology, Corp. RT5372 Wireless Adapter

When I contacted Panda Wireless yesterday, they told me the device should be plug-n-play, so I don't need to install the driver. I bought the device in January, but I still haven't used it because it's so difficult to know how to make it work. I did try to follow the instructions for creating the driver, but ran into an error with the make command. However, given that I could get the adapter to work yesterday (before I unplugged it from the front-facing USB port), it does seem to be true that it's plug-n-play. I just don't know how to coax my OS into showing me the extra options.

  • At least, can you create it manually, via terminal? – mattia.b89 Apr 16 at 8:19
  • 1
    @mattia.b89 Where are the instructions for doing so? – ahorn Apr 16 at 8:22
  • You should search on your distro's wiki... – mattia.b89 Apr 16 at 8:26
  • Where is the Linux Mint Wiki? – ahorn Apr 16 at 8:52
0

You mentioned that you ran the first three steps in the Panda Wirless Linux Users Manual.

  1. Remove the blacklist rt2800usb line you put at the end of /etc/modprobe.d/blacklist.conf
  2. As per this answer, type sudo modprobe rt2800usb into the terminal.
  3. Restart your computer.
  4. Click on the Network Connections icon in the taskbar, click on "Edit Connections", then the + to add a new connection. Choose a "Wi-Fi" connection.

  5. Set the "Mode" to "Hotspot", add an SSID, select the device by its wlan name, then go to the "Wi-Fi Security" tab and add a password with "WPA & WPA2 Personal" security.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.