0

Given the CentOS server-like machine:

$ uname -a 
Linux labsm 3.10.0-693.21.1.el7.x86_64 #1 SMP Wed Mar 7 19:03:37 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

EDIT

My initial problem was that local network is Ok, but internet was not accessible. It appeared that my machine was blocked by mac-address. Now I get my mac-address in the list of the ones allowed internet access and everything is working.

However, I have one more question about the network. The IP address in ifconfig doesn't match the one in the network-script.

I did disable the NetworkManager and configure the network-script, so that the machine has the IP address 133.21.224.237. The network-script is:

{enp96s0f1}
$vi /etc/sysconfig/network-scripts/ifcfg-Wired_connection_1

HWADDR=0C:C4:7A:F9:BA:CF
MACADDR=0C:C4:7A:F9:BA:CF
TYPE=Ethernet
PROXY_METHOD=none
BROWSER_ONLY=no
BOOTPROTO=none
DEFROUTE=yes
IPV4_FAILURE_FATAL=no
IPV6INIT=no
IPV6_AUTOCONF=yes
IPV6_DEFROUTE=yes
IPV6_FAILURE_FATAL=no
IPV6_ADDR_GEN_MODE=stable-privacy
NAME=enp96s0f1
UUID=ef4dba55-7c9a-3d8e-94b6-5e2146284e1a
ONBOOT=yes
AUTOCONNECT_PRIORITY=-999
IPADDR=133.21.224.237
PREFIX=24
GATEWAY=133.21.224.94
DNS1=10.20.0.55
DNS2=10.20.0.56
PEERDNS=no

I did restart the network service with

$ systemctl restart network

But! In the ifconfig:

enp96s0f1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 133.21.224.29  netmask 255.255.255.0  broadcast 133.21.224.255
        inet6 fe80::ec4:7aff:fef9:bacf  prefixlen 64  scopeid 0x20<link>
        ether 0c:c4:7a:f9:ba:cf  txqueuelen 1000  (Ethernet)
        RX packets 2186987  bytes 459109170 (437.8 MiB)
        RX errors 0  dropped 423238  overruns 0  frame 0
        TX packets 56064  bytes 6389505 (6.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

So, the line inet 133.21.224.29 says that the ip address ends with 29, while I configured it 237 in the network-script. Even more interestingly, the machine can be accessed inside the local network by ssh with both IP addresses...

That IP address 133.21.224.29 was assigned to that machine some time before. But I don't understand how the machine receives it now, after I changed the network-script. What am I missing?

  • Are you working for Toyota in Japan? – ctrl-alt-delor Apr 16 at 8:58
  • The first odd thing I see (though I don't think it will break anything) is 3 network adaptors connected to the same network. – ctrl-alt-delor Apr 16 at 9:02
  • I am indeed working in Japan. All adaptors are on the same motherboard, that is a feature of it. So, I think they all should be connected to the same network. Anyway, I need only one, so if there is a way to disable others - tell me! – Ivan Lobzenko Apr 16 at 9:15
  • By the way, can you briefly tell me how do you know my location from the data I shared? – Ivan Lobzenko Apr 16 at 9:18
  • I was checking that you were not using someone else's (Toyota Japan) IP address (as this could cause network problems). You have multiple adaptors, so that you can connect them to different networks. To disable two of them, unplug them. I up-voted, and see no reason for a down-vote. By the way, do you have DHCP on your network, it will help a lot. – ctrl-alt-delor Apr 16 at 9:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.