0

Mysql is down on my vps server and i tried to restart, stop then start, but nothing works.

The error i am seeing every time is this

[root@vps ~]# service mysqld restart
Redirecting to /bin/systemctl restart mysqld.service
Job for mysqld.service failed because a configured resource limit was exceeded. See "systemctl status mysqld.service" and "journalctl -xe" for details.

Output for fist command - systemctl status mysqld.service

[root@vps ~]# systemctl status mysqld.service
● mysqld.service - MySQL Server
   Loaded: loaded (/usr/lib/systemd/system/mysqld.service; enabled; vendor preset: disabled)
  Drop-In: /etc/systemd/system/mysqld.service.d
           └─limits.conf
   Active: failed (Result: start-limit) since Mon 2019-04-15 09:49:04 CEST; 57s ago
     Docs: man:mysqld(8)
           http://dev.mysql.com/doc/refman/en/using-systemd.html
 Main PID: 7038 (code=exited, status=0/SUCCESS)

Output for 2nd command - journalctl -xe

Failed to remove runtime directory /run/user/1008: Device or resource busy


[root@vps ~]# nano /etc/systemd/system/mysqld.service.d/limits.conf                                                                           

[Service]
LimitNOFILE=50000

Is there anyway to solve this ?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.