0

I am trying to disable touchpad through xinput. But I cannot find the id for my touchpad... Here is xinput list:

Virtual core pointer                          id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ DLL07A9:01 044E:120B                      id=14   [slave  pointer  (2)]
⎜   ↳ GTech MI wireless mouse Mouse             id=11   [slave  pointer  (2)]
⎜   ↳ GTech MI wireless mouse Consumer Control  id=13   [slave  pointer  (2)]
⎜   ↳ DualPoint Stick                           id=15   [slave  pointer  (2)]
⎣ Virtual core keyboard                         id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Integrated_Webcam_HD: Integrate           id=10   [slave  keyboard (3)]
    ↳ Intel HID events                          id=16   [slave  keyboard (3)]
    ↳ Intel HID 5 button array                  id=17   [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                          id=18   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=19   [slave  keyboard (3)]
    ↳ GTech MI wireless mouse System Control    id=12   [slave  keyboard (3)]
    ↳ GTech MI wireless mouse Consumer Control  id=20   [slave  keyboard (3)]

I am using dell precision 3520 and running arch linux(if that is related). Can someone tell me what id corresponds to my touchpad and how you know?

1 Answer 1

2

It should be the DLL07A9:01 044E:120B device. See Aquantia Corp. DLL07A9:01 044E:120B Touchpad.

Either do:

xinput disable DLL07A9:01 044E:120B
xinput enable DLL07A9:01 044E:120B

Or use the XID (I suspect, this is more fragile because it could change):

xinput disable 14
xinput enable 14
1
  • 1
    xinput set-prop 14 "Device Enabled" 0 would also work.
    – jackw11111
    Commented Jun 9, 2020 at 10:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .