0

I just set up a new server (OpenSuse Leap 15.0) and installed the Check_MK-Agent. Every time my Check_MK-Servers polls this agent, this socket-access ist logged:

Apr 14 20:05:26 static systemd[1]: Started Check_MK (xx.xx.xx.xx:xxxx).

As this happens every minute, my log-file is spammed with worthless information.

I already have two linux-machines monitored by my Check_MK-Server and none of them has these log-entrys. All three machines have syslogd running and I already invested hours in comparing the installations and conf-files without luck.

Does anybody know how to prevent syslogd from logging socket-calls?!

  • "Every time my Check_MK-Servers polls this agent, this socket-access ist logged". It's not Check_MK-Servers that's writing the message; it's systemd. That's where you need to look next. – roaima Apr 14 at 19:32
  • Yes, that's what I tried to say - the syslogd on the machine with the check_mk-agent is my problem. By the way: I dindn't try but I fear that every process using the syslogd-socket-mechanism would cause syslogd to genereate these entrys in my log-file... Thanks for your fast answer! – Rowham Apr 14 at 19:46
  • It's not syslogd but systemd you need to investigate. – roaima Apr 14 at 20:32
0

(copied from SU, where this was closed for some or other reason)


systemd and syslogd do not log socket calls.

The Check_MK-agent is an "inetd service" – this means it does not run persistently and does not create its own listener socket; instead it relies on a "superserver" to do this job. Every new connection is accepted by the superserver, which then starts a new copy of Check_MK to handle that particular connection.

Traditionally the inetd or xinetd superserver programs are used for this purpose. Your newly installed system however uses the "socket activation" feature of systemd to achieve the same thing – in this system, the listener socket is represented by a .socket unit and each new instance is represented by a new au­to­mat­i­cal­ly generated .service unit.

So the log message is not about socket access at all – it literally says that a service has been started. There is no option to disable service startup logging.

To get rid of this message, deactivate the systemd .socket unit and reconfigure your Check_MK-agent to be started via xinetd (or traditional inetd, or any other alternative).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.