I am not able to run/install Linux on my Lenovo ThinkPad E585. I tried both a full installation and running from the USB stick.

All I get is:

  • GRUB starting from the USB stick.
  • Select Linux installer from the USB stick.
  • A blank screen.

This is what I tried so far:

  • Distributions: Devuan, Debian, Manjaro, Artix.
    • devuan_ascii_2.0.0_amd64_netinst.iso
    • debian-9.8.0-amd64-netinst.iso
    • manjaro-kde-18.0.4-stable-x86_64.iso
    • artix-lxqt-openrc-gremlins-20190222-x86_64.iso
  • Installation media: USB stick.
  • Installation types: local, network.
  • BIOS settings: boot from USB port first; disable secure boot and UEFI/Legacy boot to both.
  • Tool to burn the OS: Rufus 3.5.1497. Tried both ISO and DD modes.
  • Partition scheme: GPT/UEFI (non CSM).
  • Init systems: SystemD (Debian, Manjaro), OpenRC (Devuan, Artix).

These are the laptop's specifications:

  • Lenovo ThinkPad E585 (AMD Ryzen 7 2700U, 8+16 GB RAM).
  • Two internal SSD drives (NVMe and SATA3).
  • Working fine with Windows 10.

I found out that to support the AMD Ryzen 7 2700U processor I need at least a kernel version 4.10. Debian 9.8 has version 4.9.30, Devuan 2 has version 4.9.82, Manjaro 18 has version 4.19.28 and Artix has version 4.18.10. So the first two ones should fail to install, but the last two ones should succeed; what happens to me is that they all fail in the same way, i.e. a blank screen after GRUB selection.

The fact I chose a GPT partition scheme instead of a MBR one should not be relevant at this stage.

I ran out of ideas.



Pietro, in my experience you need a slightly newer kernel than those: I started getting a usable system after 4.20 and I got up to 5.0.4.

You can always install in text mode and later update the kernel, of course.

  • Andrea, my problem is that I cannot even install a base Linux system, from which to make an upgrade. Not even an USB live distro.
    – Pietro
    Apr 14 '19 at 16:43
  • That is weird. Shutting up, then. Will follow up if I find something useful. Apr 14 '19 at 17:25
  • Grazie Andrea. Eventually I will wait for a distribution to be released with the latest kernel. Hopefully they will not take too long...
    – Pietro
    Apr 14 '19 at 22:11

I'm running Fedora 29 64bit on my E585. I followed the guide on enter link description here. Especially the kernel boot parameters ivrs_ioapic[32]=00:14.0 ivrs_ioapic[33]=00:00.1 seem to be important. Unfortunately I'm not familiar with these things so I can just provide the link to this guide.


I have a E585 with the Ryzen 5 2500u and had the same issue. You need to add noapic to grub by hitting "e" when you are in the grub menu. More details and steps at my blog.


To install Linux on a Lenovo ThinkPad E585, it is necessary to upgrade the BIOS. The one provided (at least when I bought it) has some issue, which have now been fixed with the end-of-August 2019 release.

With the new BIOS, the installation is as smooth as usual.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.