0

When I start and log into my computer, multiple programs open on startup (mousepad, a terminal and firefox). How can I change this behaviour? I have no idea why it happens.

I am running Manjaro XFCE. I already tried using the graphical option menu, which does not list the programs mentioned above in the current startup applications.

  • 1
    You can look in ~/.xsessionrc file. – ctac_ Apr 13 at 9:42
  • For some reason, this file does not seem to exist on my system. – Jonas Schwarz Apr 13 at 10:17
  • 1
    There is a lot of possibility to open programs at startup. ~/.xsessionrc is one, autostart is another. On my debian, /etc/X11/Xsession.d/ is another one. I don't use Manjaro so I can't tell you. You can try to ask on Manjaro forum or here. – ctac_ Apr 13 at 11:13
1

You can delete the cache folder in your home folder. You'll want to uncheck 'Automatically save session on logout' under 'Sessions and Startup' as well.

rm -rf ~/.cache/
0

Following the advice from ctac_, i checked multiple possibilities to open applications at startup, but did not find anything that caused my problem. On the Arch forums someone had a similar problem, albeit while running Arch.

Their solution was to clear a faulty saved session by enabling the option "Automatically save session on logout" in the "Sessions and Startup" options, closing all applications and restarting XFCE. Afterwards, the enabled option may be disabled again.

This approach has worked for me as well :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.