2

Having a really weird problem with NFS mounts. When I mount my exports on my clients the directory and the files within are readable, but I can't write to the exported directory from the client neither can I enter hidden directories (~/.config) for example. When I list the files within the .config directory I get this:

?????????? ? ? ? ?            ? nautilus
?????????? ? ? ? ?            ? nemo
?????????? ? ? ? ?            ? nitrogen
?????????? ? ? ? ?            ? openbox
?????????? ? ? ? ?            ? OpenSCAD

/etc/export on server

/home/user 192.168.178.33(rw,sync,no_root_squash,no_subtree_check,anonuid=1001,anongid=1001,nohide,crossmnt)

/etc/fstab on client

192.168.178.100:/home/user /home/user nfs rw,noauto,hard,user,exec 0 0
  • KIndly restart the nfs service and Umount the directory in client and remount it – Praveen Kumar BS Apr 13 at 8:26
  • What is the output of ls -ld /home/user/.config on the server? The directory probably has the r bits but not the x bits. – Mark Plotnick Apr 13 at 14:18
  • I tried restarting and rebooting already. The umask on the server is completely fine. All permissions are set properly. – mad_a_i Apr 13 at 18:24
  • As I said I neither can create files nor can I enter hidden directories. Normal directories work fine. – mad_a_i Apr 13 at 18:25
  • If you're still working on this, have you tried backing off of the mount restrictions to figure out which one is causing the problem? I.e - just try with defaults and build from there? Also, I was messing with something earlier in the week and, like Mark mentioned, ran into a +x issue where the output was almost identical to what you're seeing. – kevlinux Apr 19 at 4:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.