After I tried to install swift on my Debian 9 machine, Suddenly I faced a big problem (I couldn't access Debian GUI) I solved this issue by some terminal command like

sudo apt-get install gdm3 and apt-get install firmware-misc and more.

Now I can access my GUI normally but,

  1. I cannot open my user account (on login screen I can insert my user name and password but I cannot login, The two text boxes become empty after I hit login) when I logged in with root I can get access to my user name via terminal.
  2. I cannot open Firefox browser.
  3. I cannot open Opera browser.

The message file on /var/log/message

says Error reading existing Xauthority: Failed to open file “/home/amraly/.Xauthority”: Permission denied

I think that number 2 and 3 can solve by install them again but number one is my main problem.

  • 2
    What did you do just before "suddenly"? What were the terminal commands you issued afterwards? What happens when you try to launch the browsers? Are there any relevant information in any of the system's logfiles? – Kusalananda Apr 11 '19 at 8:22
  • Consider adding clarifications in the question rather than as comments. – Kusalananda Apr 11 '19 at 12:25

Debian has a synaptic package manager from system tools. I fixed all the broken packages I found it in the synaptic manager, then my account returned and my Debian copy returned normal without any error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.