1

I'm trying to get constant maximum performance on my HP Proliant server running CentOS 7. Current configuration of using intel_pstate driver which varies clock speed between 1.2GHz - 2.4GHz isn't working. I want to fix the clock speed at 2.4GHz and the scaling frequency governor "performance" isn't allowing me to do that.

  • When you talk about "maximum performance" is to have the CPU running at its maximum frequency all the time? – Paradox Apr 10 at 22:21
  • @Paradox: Yes sir. That would be an ideal environment for me. Thanks! – Kstar174 Apr 10 at 22:30
  • 1
    Not using maximum frequency is a feature not a bug. It is the expected behavior. Intel Turbo Boost Technology is a way to automatically run the processor core faster than the marked frequency. The processor must be working in the power, temperature, and specification limits of the thermal design power (TDP). This results in increased performance of both single and multithreaded applications. There is no need to install any software or application to support Intel® Turbo Boost Technology. Unless your CPU does not increase its frequency under load, you have no problem. – Paradox Apr 10 at 22:37
  • @Paradox: Thanks for pointing towards Turbo Boost. I will retain stock config & enable Turbo Boost and try out. – Kstar174 Apr 10 at 22:47
  • 1
    @Kstart174 Unless you have some weird setting in the BIOS, it should be enabled by default (or not even able to choose). It is very likely that it's enabled and you did not notice that your CPU frequency was higher under load. Or that the temperature around your CPU is too high to avoid throttling. – Paradox Apr 10 at 22:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.