0

Debian-9.8-netinst, Supermicro X8STI-3F (Xeon E5504, 2.00 GHz, Bios ver 1.0c, LSI MegaRaid 8208ELP (rev 08) with four SAS HDD 146Gb Seagate. During installation debian doesn't recognize HDDs.

What was done:

  1. Four separate RAID0 disks was created in MegaRaid Utility. During installation these HDDs doesn't shown up in partmanager. Then installer was booted up with options expert dmraid=true and expert mdadm=true - nothing, no HDDs. But installer (in separate console) sees these 4 HDDs as `/dev/sdXX', I can access them, get info etc.
  2. According to previous I tried next thing: fdisk /dev/sdX on each HDD and wrote changes. After reboot RAID said, that disks are not online, I continued, and - VOILA - debian sees all 4 separate disk. So, I successfully installed debian on mdadm-created array.

BUT - after reboot motherboard BIOS doesn't see ANY HDD in boot options, in boot menu, so I can't boot from installed linux! But MegaRaid BIOS sees and show all these HDDs...

Tried using non-free version of debian installer - nothing.

mdadm --zero-superblock /dev/sdX said "no write access". Only using fdisk as above I could zero HDDs and create GPT partition table.

Tried to switch jumper on motherboard from SW RAID to IP - it even doesn't start HDDs.

BIOS has only one option of SAS - "Advanced PCI/PnP Settings -> Load onboard SAS Option ROM" with "Enabled/Disabled" state

RAID BIOS doesn't have any options of "mapping" HDDs to MB BIOS.

So, how can I install debian on these hardwarem not using fake-RAID?

  • Is the question confusing HW w/ software RAID? – Rui F Ribeiro Apr 10 at 15:31
  • I do not need SW RAID from supermicro, I only need from server to see SAS HDD as separate devices. Then I plan to use mdadm – Someone Apr 10 at 15:55
0

To show separate SAS HDDs two things has to be done:

  1. LSI SAS controller has to be flashed to support IT-mode instead of RAID only mode. Here: ftp://ftp.supermicro.com/driver/SAS/LSI/1064_1068/IT/Firmware/B3/L8i/1.30.00/ - is firmware for my controller and DOS/Win/Linux flash program in archive. As for me I successfully booted SystemRescueCD x64 from USB and flashed up controller.

  2. Motherboard jumper JPS2 (RAID On/Off) has to be unlocked (X8STI-3F m/b).

After that SAS HDDs are powered up, LSI configuration utility shows CTRL-C to configure conroller (instead of CTRL-M in RAID mode), motherboard's BIOS sees these HDDs as bootable devices in F11 boot menu.

Then, pass expert dmraid=true boot installer, switch to console and zeroing each HDD using fdisk /dev/sdX and writing changes. Again reboot to debian installer with expert dmraid=true and, at last!, I can see HDDs and can continue installation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.