0

I am trying to run Windows 98 on QEMU on my Pi using a project I found here: https://www.hackster.io/314reactor/windows-98-wrist-watch-15ecfd . When I run

qemu-system-i386 -localtime -cpu 486 -m 96 -hda windows98.img

I am told

WARNING: Image format was not specified for 'Windows98.img' and probing guessed raw.
Automatically detecting the format is dangerous for raw images, write operations on block 0 will be restricted.
Specify the 'raw' format explicitly to remove the restrictions.

QEMU still opens but it reads

Disk I/O error replace the disk then press any key

the same message continues to come up when any key is pressed. I ran the code

qemu-system-i386 -drive format=raw,file=Windows98.img 

to try and get the raw format message to go away, which worked, however in QEMU the Disk I/O error message still appears.

  • Welcome to Unix & Linux :-) It looks like something went wrong when you created the Windows 98 image file here... – Fabby Apr 10 at 12:28
  • i downloaded the img file from a website online instead of that. I should have said that in my initial post. – Matt Apr 25 at 11:57
  • Then it means you've got a corrupted image file. Please follow the process to create your own file or contact Microsoft for a CD (they can still be had) – Fabby Apr 25 at 16:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.