-1

I do use virtualization a lot , and of course my favorite tool is kvkm-qemu. However I am extremely frustrated with it lately, all my attempts to create a redhat based virtual machine with centos,opensuse and etc has failed so far and I cannot pinpoint the issue in any way.

I try to create the virtual machine using the virt-manager on my own host and after successful installation I transfer the host to the container machine. The funny part is that I created a centos guest 2 weeks ago successfully and painfully . The guest will stuck for no reason at different stages of the boot, I force reboot and then boots and stucks again is somewhere else , sometimes it boots up completely but cant run the setup , I changed all of my iso files I re-downloaded them and verified them , I tried different settings for hardware and also tried nomodeset with the kernel, it boots it installs but then it wont boot again.

Out of my frustration I used the virtualbox and vmware workstation to create the guests flawlessly then converted the guests for the container machine successfully but again they wont boot with this method.

I assign:

1X cpu 
512 MB of ram
30GB HDD 

to each guest. Anyway so here is the annoying part, when creating a debian based guest such as ubuntu :-/ it just like 1,2,3 piece of cake no issues and no matter how I do it and on whichever virtualbbox,kvm or vmware then convert it to raw or .qcow2 it works. I bet even if I transfer it to the mars it will still work. Its so annoying.

I USE:

[root@athena odin]# cat /etc/os-release 
NAME=Fedora
VERSION="29 (Workstation Edition)"
ID=fedora
VERSION_ID=29
VERSION_CODENAME=""
PLATFORM_ID="platform:f29"
PRETTY_NAME="Fedora 29 (Workstation Edition)"
ANSI_COLOR="0;34"
LOGO=fedora-logo-icon
CPE_NAME="cpe:/o:fedoraproject:fedora:29"
HOME_URL="https://fedoraproject.org/"
DOCUMENTATION_URL="https://docs.fedoraproject.org/en-US/fedora/f29/system-administrators-guide/"
SUPPORT_URL="https://fedoraproject.org/wiki/Communicating_and_getting_help"
BUG_REPORT_URL="https://bugzilla.redhat.com/"
REDHAT_BUGZILLA_PRODUCT="Fedora"
REDHAT_BUGZILLA_PRODUCT_VERSION=29
REDHAT_SUPPORT_PRODUCT="Fedora"
REDHAT_SUPPORT_PRODUCT_VERSION=29
PRIVACY_POLICY_URL="https://fedoraproject.org/wiki/Legal:PrivacyPolicy"
VARIANT="Workstation Edition"
VARIANT_ID=workstation


[root@athena odin]# lscpu
Architecture:        x86_64
CPU op-mode(s):      32-bit, 64-bit
Byte Order:          Little Endian
CPU(s):              4
On-line CPU(s) list: 0-3
Thread(s) per core:  1
Core(s) per socket:  4
Socket(s):           1
NUMA node(s):        1
Vendor ID:           GenuineIntel
CPU family:          6
Model:               158
Model name:          Intel(R) Core(TM) i5-7300HQ CPU @ 2.50GHz
Stepping:            9
CPU MHz:             1000.019
CPU max MHz:         3500.0000
CPU min MHz:         800.0000
BogoMIPS:            4992.00
Virtualization:      VT-x
L1d cache:           32K
L1i cache:           32K
L2 cache:            256K
L3 cache:            6144K
NUMA node0 CPU(s):   0-3
Flags:               fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx pdpe1gb rdtscp lm constant_tsc art arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc cpuid aperfmperf tsc_known_freq pni pclmulqdq dtes64 monitor ds_cpl vmx est tm2 ssse3 sdbg fma cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic movbe popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm abm 3dnowprefetch cpuid_fault epb invpcid_single pti ssbd ibrs ibpb stibp tpr_shadow vnmi flexpriority ept vpid ept_ad fsgsbase tsc_adjust bmi1 avx2 smep bmi2 erms invpcid mpx rdseed adx smap clflushopt intel_pt xsaveopt xsavec xgetbv1 xsaves dtherm ida arat pln pts hwp hwp_notify hwp_act_window hwp_epp flush_l1d


              total        used        free      shared  buff/cache   available
Mem:          11887        5467         771         608        5648        5489
Swap:          6011        1006        5005

as my HOST machine. with the kernel version of 5.0.5-200.fc29.x86_64. the basic settings that i use for each guest in kvm is as follows:

enter image description here

btw. the reason I create the guests on a different machine is that the container machine is headless and I have better flexibility doing what I do here. I can test the guests before doing the actual thing on the container for security reasons , but still if I do it on the container ( I tried ) directly it won't work at all. The container is AMD based CPU and my workstation is INTEL.

  • Why do you call the other machine "container machine"? Why don't you just create the VM directly on that machine? You already have virt-manager, just set up a new connection. – Michael Hampton Apr 11 at 3:52
  • thank you for pointing out the obvious but a container machine as it indicates contains a cluster of virtual machines. it however has been modified for security reasons based on various standards. we do have linux based containers which are kvm based or you can just create your own container machine anyhow you desire. – linuxismyworld Apr 11 at 6:11
  • 1
    This is very confusing. You keep saying "container" but that word doesn't make sense in the context you have used it. You seem to be talking about virtual machines, but containers are something else entirely, and I don't understand why you mention containers at all here? It doesn't make sense. – Michael Hampton Apr 11 at 6:27
  • Dont be confused it is very simple , virtual machines will be created and tested before transferring them to the container server and bringing them to production. You dont directly create virtual machines on the container system that would be against our security policy . Each guest must be tested and passes all the security checks before it being allowed on the container system. – linuxismyworld Apr 11 at 8:08
  • There are thousands of terms used in computing some might have similar names but entirely different definitions. Kubernetes and cloud also have container in their definitions. On this particular subject we refer to linux containers which are servers capable of virtualization in large scale, securing them is another practice. For example VMware EXSI SERVER is a container OS. You install it on a bare metal or just a very powerful server and it will host tens of guest machines and it is called container. – linuxismyworld Apr 11 at 8:12
0
  • CentOS 7.0 is quite obsolete, does it fail also with recent 7.6?

  • 512MB of RAM is far low under RHEL/CentOS7 recommendations - 2GB. It is probably too little!

  • i forgot to mention that i have downloaded the latest ISO from the centos , and also assigned 2gb ram for the installation purposes, i do have a centos 7.6 created with the minimal specifications i stated such as 512 MB of ram and it works perfectly , but that was two weeks ago as i said and for that one i literally had to reset the machine 25 Times before it could bring up the installation . i am baffled with this issue i cant seem to pinpoint what the problem is . – linuxismyworld Apr 10 at 11:13
  • Also I cant pinpoint why after like a hundred times restarting the installation it stucks in various stages , it progresses then stucks somewhere else then again after rebooting it passes that stage then get stuck somewhere else , I have tried increasing the number of CPU and the RAM to 8GB and 4 CPU. to pass the minimal requirements but still nothing. Now if I'm to install any debian derivative it goes without any issue even with 256mb of ram. This bothers me why debian is ok with it but not Any of the redhat derivatives. – linuxismyworld Apr 11 at 8:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.